Videos don't play


#1

Videos don’t play in rtMedia. Users click Media>Videos>Upload and successfully upload mp4 videos. The video_thumb.png image appears and when clicked, the video player appears but it’s completely black except for the white triangular play button (no image of the uploaded video). When the play button is clicked it just remains black and there is no video playback. I’ve tried uploading several different videos, both avi and mp4 and of various sizes, none of which has played. I’ve tried this in Mozilla Firefox, Internet Explorer, and Google Chrome. The video hasn’t played in any of them. I’m using WordPress 4.0 (it didn’t work for me in WordPress 3.9.2 either) with BuddyPress version 2.1 and rtMedia version 3.7.13 (it didn’t work for me with rtMedia version 3.7.3 either). I have deactivated all plugins except for BuddyPress and rtMedia but this has not resolved the problem. My website is hosted with Hostgator in an Aluminum reseller hosting account which is shared hosting. I’m using a Gateway computer with Windows 8 and 4GB of RAM. A technician in another part of the USA tried to view the video, using various browsers on his computer, and he had similar results. How can this problem be resolved?


#2

I had been uploading and trying to play avi videos and avi videos that were converted to mp4, neither of which played. Later I found a free sample mp4 video, uploaded it to a user profile and it did play. I just don’t understand why my other short mp4 videos won’t play. I don’t understand why one mp4 video will play and another won’t.


#3

Hi Brian,

There was some issue with encoding service and it wasn’t converting the videos. So, I think your previous videos weren’t converted. Please check with new uploads and let us know.


#4