Video doesn't play: "Content-Type" of "text/plain" is not supported


#1

I’m using rtMedia on a BuddyPress site. It appears that I can upload video just fine: I upload the video, and the player appears. But when I click the video, it says the video length is 0 and it doesn’t play - the spinner icon just spins endlessly. When I hit “play” with the Firebug console enabled, I get the following error:

HTTP “Content-Type” of “text/plain” is not supported. Load of media resource http://url-of-video.mp4 failed.

What can I do to fix this?


#2

Check settings in rtMedia for allow media type under rtMedia->Settings->Types. The video must be enable.


#3

Video is enabled - that’s not the problem.


#4

Any more suggestions about what I can do to fix this problem? I can give you admin access to the site if that would help.


#5

Hi Morgan,
just for reference, can you check it in chrome as well? Also make sure your none of the browser addons creating conflict which prevent to load video files.


#6

It works in Chrome, but not in Firefox.


#7

Hi Morgan,
I just checked our demo site -> http://demo.rtcamp.com/rtmedia/ in firefox and is working fine. Let me know if that works in your system or not?


#8

The demo site works fine on my computer.

I tried disabling all plugins, and that didn’t help.


#9

Hi Morgan,
I am sorry to say but I can’t help you as our demo works perfectly fine and not your site. Have you tried default WordPress theme? Also check on fresh WordPress setup.


#10