Using HHVM with php-fpm fallback configuration in Ubuntu 14.04 64bit clean install


Dear EasyEngine Community User.

This is my first thread for EasyEngine. I am highly satisfied with EasyEngine because of it’s well defined tutorial and community.

However some tutorial is out of dated, so I couldn’t configure well for the current situation.

Like many other people, I would like to optimize my website using EasyEngine, so I follow the Using HHVM with PHP-FPM Fallback( after clean Ubuntu 14.04 64bit.

I installed my website for using wp with hhvm and letsencrypt option ee site create --wp --hhvm --user=admin --pass=password --letsencrypt

In the “Use HHVM and adding PHP5-FPM as fallback:” Section, When I opened my Upstream.conf file, I can check the following information.

Common upstream settings

upstream php {

server unix:/run/php5-fpm.sock;

server; } upstream debug {

Debug Pool

server; }

upstream hhvm { server; server backup; }

When I change the cons file like the tutorial, nginx couldn’t start properly.

Common upstream settings

upstream php {

server unix:/run/php5-fpm.sock;

server; server backup; }

upstream debug {

Debug Pool

server; }

There are some document in the google, however I couldn’t find the proper solution because I am using EasyEngine.

Do you know the beautiful solution for my situation?


Honggi An


Just a heads up on HHVM’s longevity with EasyEngine. Before you settle for HHVM, I suggest you read this thread first if you haven’t already:


Thanks Nichlas, It seems that you didn’t recommend using HHVM with EasyEngine, right?

I would like to optimize using EasyEngine, when the tutorial will be updated properly, maybe we can save much time each other. I am positive for paid user tutorial view option in this site.


For my own business and performance needs, I never saw any appeal in using HHVM over PHP 7.

Also, if you’re new to EasyEngine, I would definitely recommend you go with PHP 7 instead.


Thank you so much for your reply. I will consider using php7 instead of HHVM.


Where did you find this code? It’s not in the original article if you were following it. There are only two blocks:

upstream php and upstream debug, there’s no upstream hhvm…


That code has been generated by automatically in my situation Ubuntu 14.04 64bit LTS version.


My bad, yes it now present in upstream.conf, I apologize. OK so when you’re saying nginx couldn’t restart properly, what error(s) do you see in logs?


Dear Tyrro

Sorry for late response, I already deleted the os and EazyEngine, so I have to reinstall to reply your question.

From the clean install, the “php5-fpm -t && service php5-fpm restart” command doesn’t work with this error “The program ‘php5-fpm’ is currently not installed. You can install it by typing: apt-get install php5-fpm”

So when I type apt-get install php5-fpm, I should install

“php5-common php5-fpm php5-json” too

Here is the main reply for your question.

root@test:~# nginx -t && service nginx restart nginx: [emerg] no port in upstream “hhvm” in /etc/nginx/common/php-hhvm.conf:9 nginx: configuration file /etc/nginx/nginx.conf test failed


It looks like your install is broken. I would start fresh and then move your sites to new server.