Use Lets Encrypt when folder name is different than domain name


#1

Hi there,

We have a lot of domains on a server, but the folder name is not the domain name. When we create a site we need to develop it first before we release it so we use domain like name.wp.domainname.com so the folders get similar name. When the site will be released we add some stuff in a server.conf file but the folder name is the same as before. Now I want to add Lets Encrypt on these domains which need it and I got errors ,but I neither get any ssl on the released domain (ERR_CERT_COMMON_NAME_INVALID). The problem here is I got ssl for the name.wp.domainname.com and not the domain.com

Any workaround or ideas here? The best should if I can name the domain in ee command line like --letsencrypt --domain.com

/Thanks


#2

Hi MickePalm,

if your domain is created using EasyEngine, you could use the following command to enable SSL.

ee site update name.wp.domainname.com --letsencrypt

For more information please refer the following url

https://easyengine.io/docs/lets-encrypt/

If the site is not created using EasyEngine, you will need to enable letsencrypt manually.


#3

I use EE to create a site and when I use --letsencrypt I got SSL on wrong domain. Please read my question again :slight_smile:

/Thanks


#4

Perhaps you should use symlinks to workaround the directory name changes.

You won’t be able to remove them, though, because they’ll be needed in order to periodically renew your domains.


#5

Good idea! It might work. Should Nginx point to the link folder than the original folder?

I think if EE could take a one more argument here like the domain name it should work…


#6

I think EE will update your vhost .conf file and point it to the symlink as soon as it installs the SSL.

But you gotta try it for yourself, don’t take my guesses as true.


#7

I will try it out. If any have any better solutions on this, please respond :slight_smile:


#8

Hey Mike,

In case you haven’t figured this out until now:


#9