URGENT HELP NEEDED ... Site broken while trying to install ioncube


#1

I was installing ioncube on my server and I accidentally screwed up everything.

To make matter worse I removed and reinstalled php-fpm etc.

Now all I get when i go to my website is 502 bad gateway.

Can anyone help me get my site up? Also will I be able to get my wordpress sites that were running back? I have no backup :frowning:

Thanks so much for your attention and help.


#2

@synergiesunlimi,

What PHP version you were using with Ioncube? As per my understanding Ioncube not works well with PHP greater than 5.3

Just use follwoing commands to purge php:

ee stack purge php

and install php again

ee stack install php

#3

@gau1991

Thanks so much for taking the time to reply.

The PHP version I am running is the one that ee initially installs on the server.

I tried to purge php and it went well.

But when I went to install php again as per ‘ee stack install php’ command, it gave me the following message:

Setting up PHP5, please wait… Downloading GeoIP Database, please wait… Executing service php5-fpm restart, please wait… [ Tue Dec 2 10:43:10 EST 2014 ] Unable to execute service php5-fpm restart, exit status = 254

Thanks once again for your reply. Your valuable inputs are highly appreciated.

Mark


#4

it look like there is configuration error in your PHP.

you can check that using php5-fpm -t


#5

Gaurav… You are AWESOME.

You were absolutely right. I messed up my php configuration file and hence the error. Here’s what happened:

I edited the php.ini file to insert the zend_extension line. However I did it at the end. That line needs to go right at the beginning of the php.ini file. Hope this information helps someone.

Thanks a ton for your timely help Gaurav. God bless you.


#6

Hi @synergiesunlimi

Glad that your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#7