Uploads on buddypress aren't showing up. Only the status you put with the photo appears


#1

Hi,

For some reason, when i try to upload a photo to my buddypress site on the activity feed, the photo uploads fine, but when you press post update, the picture doesn’t appear on the status, only the text.

It worked at some point on another domain, but since we transferred the domain, it’s got the activity stream with the pictures uploaded on the old domain, but whenever i try to add a picture now, it doesn’t work.

Any advice?

Thanks in advance


#2

Hi @computor5,

Can you please check it once with WordPress default theme and with other plugins disabled?


#3

i have same problem exactly like you. The older site is working fine, but when i move the website, then suddenly the issue appear (the photo not appear only the text). I’m curious if the problem has been solved? I can’t find any solution in this forum. Change to default theme and only activate buddypress and rtmedia not solving this issue. Is there any info i should know regarding this issue?


#4

I have the same problem too. Only status text get posted but photo deos not. How can I fix it?


#5

Hello @Asse_Darmawansyah, @NijatR,

Can you please check if there exists any javascript error in browser console or any server errors?

Thank you.


#6

Hello, @pranalipatel

I have these two errors:

How can I fix it?

Thank you.


#7

I have no error in my console. But it still not showing the uploaded media in buddypress activity


#8

Hi my problem has been solved. The cause of the problem is the setting in php.ini. There is no value in file_uploads in php.ini.

I replace the value with file_uploads =“1” then the media upload start showing when i upload a new media.

@NijatR @pranalipatel


#9

Hello @NijatR,

Can you check when you click on ‘Post Update’ button, it’s posting the image by ajax call or the page is getting refreshed instead?

@Asse_Darmawansyah, Glad to know your issue has been solved.

Thank you.


#10

Hello @pranalipatel,

Sorry, but I don’t know how to check it. If you mean “Does page reload when click post”, no it doesn’t reload. Else, I don’t know what you mean.

Thanks.


#11

@pranalipatel Thank you very much for your attention. I solved the problem. The reason was the wrong coded jqery code in footer.php.


#12

You are welcome @NijatR, Glad to know that your issue has been solved.

Thank you!


#13