Uploading anything over 100MB times out in WordPress


#1

I’ve changed settings in custom.ini and even modified nginx.conf and main.conf, still times out.

# custom.ini
upload_max_filesize = 1000M
post_max_size = 1000M
max_input_time = 6000
max_execution_time = 3000
memory_limit 2048M

# nginx.conf and main.conf
client_max_body_size 1000m;

Am I missing anything else?


#3

Hi,

Did you set the limit in customs.ini as well?

/opt/easyengine/sites/DOMAIN.COM/config/php/php/conf.d/customs.ini

And add:

upload_max_filesize = 1000M
post_max_size = 1000M

After that restart Nginx and Apache: ‘ee site restart DOMAIN.COM’.

And the uploading should start to work.

Note: If you are using CloudFlare then the upload limit in your case might be 100mb by default.


#4

Still didn’t work. According to Cloudflare, 100mb limit only applies when you have the orange cloud icon on for free plans. I have that disabled and have Lets Encrypt on.

I have opened an issue on their GitHub here: https://github.com/EasyEngine/easyengine/issues/1384