Upgraded from RC2 to 4.0.3, now cannot create a site


#1

Hi all. I have been using 4.0.0rc2 for a bit and all was well. I’ve just updated it to the most recent release, 4.0.3 and it migrated fine. My existing sites are running. However I can’t create any new sites. Attached output from the debug below … cleaned sensitive info

Debug: ----------------------- (0.021s)
Debug: COMMAND: docker ps > /dev/null (0.021s)
Debug: RETURN CODE: 0 (0.113s)
Debug: ----------------------- (0.113s)
Debug: ----------------------- (0.113s)
Debug: COMMAND: command -v docker-compose > /dev/null (0.113s)
Debug: RETURN CODE: 0 (0.115s)
Debug: ----------------------- (0.115s)
Debug (bootstrap): Using default global config: /opt/easyengine/config/config.yml (0.117s)
Debug (bootstrap): No project config found (0.117s)
Debug (bootstrap): argv: /usr/local/bin/ee site create test.mysite.com --type=wp --cache --ssl=le --admin-user=admin --admin-email=admin@example.com --admin-pass=pass --debug (0.117s)
Debug (bootstrap): Running command: site (0.117s)
Debug (bootstrap): Running command: site create (0.119s)
Debug: COMMAND: which docker (0.127s)
Debug: RETURN CODE: 0 (0.127s)
Debug: ----------------------- (0.127s)
Debug: COMMAND: docker inspect -f ‘{{.State.Running}}’ ee-global-nginx-proxy (0.127s)
Debug: STDOUT: true
(0.182s)
Debug: RETURN CODE: 0 (0.182s)
Debug: ----------------------- (0.182s)
Debug: ----------------------- (0.182s)
Debug: COMMAND: docker inspect --format ‘{{ (index (index .NetworkSettings.Ports “80/tcp”) 0).HostPort }}’ ee-global-nginx-proxy (0.182s)
Debug: STDOUT: 80
(0.239s)
Debug: RETURN CODE: 0 (0.239s)
Debug: ----------------------- (0.239s)
Debug: ----------------------- (0.239s)
Debug: COMMAND: docker inspect --format ‘{{ (index (index .NetworkSettings.Ports “443/tcp”) 0).HostPort }}’ ee-global-nginx-proxy (0.239s)
Debug: STDOUT: 443
(0.295s)
Debug: RETURN CODE: 0 (0.295s)
Debug: ----------------------- (0.295s)
Debug: ----------------------- (0.295s)
Debug: COMMAND: docker network inspect ee-global-backend-network (0.295s)
Debug: STDOUT: [
{
“Name”: “ee-global-backend-network”,
“Id”: “4f3e95eb181cfcb51a44b898569268507a941a2d91d168b403c80bae1b347caa”,
“Created”: “2018-11-02T11:45:56.882316263Z”,
“Scope”: “local”,
“Driver”: “bridge”,
“EnableIPv6”: false,
“IPAM”: {
“Driver”: “default”,
“Options”: {},
“Config”: [
{
“Subnet”: “172.18.0.0/16”,
“Gateway”: “172.18.0.1”
}
]
},
“Internal”: false,
“Attachable”: false,
“Ingress”: false,
“ConfigFrom”: {
“Network”: “”
},
“ConfigOnly”: false,
“Containers”: {
“0dce07a227c92d60708bcc7ab025a2a648f5686563455268b0ab0bda392ac210”: {
“Name”: “mysitedotcom_php_1”,
“EndpointID”: “c33482045bc4b8fb402009a11c795ce125bdb25d171a39986cdf3b51763f91cb”,
“MacAddress”: “02:42:ac:12:00:17”,
“IPv4Address”: “172.18.0.23/16”,
“IPv6Address”: “”
},
“41e4c956499ec95bcb816933aa16f67feaa879380596fbcafe50d33b8993eed2”: {
“Name”: “ee-global-db”,
“EndpointID”: “1112a083322853a663e1f6078ddf3974f9e32699f89a930c6c9eda23973628b3”,
“MacAddress”: “02:42:ac:12:00:10”,
“IPv4Address”: “172.18.0.16/16”,
“IPv6Address”: “”
},
“e680def19b6b50e61f0a98769800b0dc363253b3c9e06c22c661f4e384b9a61f”: {
“Name”: “mysitedotcom_nginx_1”,
“EndpointID”: “b3f2324665b491ce1e338dc106121d764862796a1d47650c403d63dd8dc69b7b”,
“MacAddress”: “02:42:ac:12:00:1d”,
“IPv4Address”: “172.18.0.29/16”,
“IPv6Address”: “”
},
“f38df54ab53a2dc9119fe74fbef5335431a31c4b4f5e3ac4de940790710e108c”: {
“Name”: “ee-global-redis”,
“EndpointID”: “40c5be4c282ca219b58fef0b7743623691ec12e7508c6ed86061ec8d04888680”,
“MacAddress”: “02:42:ac:12:00:11”,
“IPv4Address”: “172.18.0.17/16”,
“IPv6Address”: “”
}
},
“Options”: {},
“Labels”: {
“org.label-schema.vendor”: “EasyEngine”
}
}
]
(0.353s)
Debug: RETURN CODE: 0 (0.354s)
Debug: ----------------------- (0.354s)
Debug: ----------------------- (0.354s)
Debug: COMMAND: docker network inspect ee-global-frontend-network (0.354s)
Debug: STDOUT: [
{
“Name”: “ee-global-frontend-network”,
“Id”: “a8116ba5ddfa65944cb7679abac4e5511e5a1e045ab59f01a50094bf7dc28489”,
“Created”: “2018-11-02T11:45:57.038266677Z”,
“Scope”: “local”,
“Driver”: “bridge”,
“EnableIPv6”: false,
“IPAM”: {
“Driver”: “default”,
“Options”: {},
“Config”: [
{
“Subnet”: “172.19.0.0/16”,
“Gateway”: “172.19.0.1”
}
]
},
“Internal”: false,
“Attachable”: false,
“Ingress”: false,
“ConfigFrom”: {
“Network”: “”
},
“ConfigOnly”: false,
“Containers”: {
“5d87a6ca8416f54dd999c8fec8795f26fd17f812853c8ab7d5b12ad0339d8fe9”: {
“Name”: “ee-global-nginx-proxy”,
“EndpointID”: “30d459c312a937de8293712155ff04414d4067594752d7d878c192deaceccfdc”,
“MacAddress”: “02:42:ac:13:00:05”,
“IPv4Address”: “172.19.0.5/16”,
“IPv6Address”: “”
},
“e680def19b6b50e61f0a98769800b0dc363253b3c9e06c22c661f4e384b9a61f”: {
“Name”: “mysitedotcom_nginx_1”,
“EndpointID”: “2c69dfbf7c8346bd717b3c002b2adf794abc18614b30bdd391a801e3c5db5bde”,
“MacAddress”: “02:42:ac:13:00:0e”,
“IPv4Address”: “172.19.0.14/16”,
“IPv6Address”: “”
}
},
“Options”: {},
“Labels”: {
“org.label-schema.vendor”: “EasyEngine”
}
}
]
(0.409s)
Debug: RETURN CODE: 0 (0.409s)
Debug: ----------------------- (0.409s)
Debug: COMMAND: which docker (0.411s)
Debug: RETURN CODE: 0 (0.411s)
Debug: ----------------------- (0.411s)
Debug: COMMAND: docker inspect -f ‘{{.State.Running}}’ ee-global-redis (0.411s)
Debug: STDOUT: true
(0.467s)
Debug: RETURN CODE: 0 (0.467s)
Debug: ----------------------- (0.467s)
Debug: ----------------------- (0.467s)
Debug: COMMAND: docker network inspect ee-global-backend-network (0.467s)
Debug: STDOUT: [
{
“Name”: “ee-global-backend-network”,
“Id”: “4f3e95eb181cfcb51a44b898569268507a941a2d91d168b403c80bae1b347caa”,
“Created”: “2018-11-02T11:45:56.882316263Z”,
“Scope”: “local”,
“Driver”: “bridge”,
“EnableIPv6”: false,
“IPAM”: {
“Driver”: “default”,
“Options”: {},
“Config”: [
{
“Subnet”: “172.18.0.0/16”,
“Gateway”: “172.18.0.1”
}
]
},
“Internal”: false,
“Attachable”: false,
“Ingress”: false,
“ConfigFrom”: {
“Network”: “”
},
“ConfigOnly”: false,
“Containers”: {
“0dce07a227c92d60708bcc7ab025a2a648f5686563455268b0ab0bda392ac210”: {
“Name”: “mysitedotcom_php_1”,
“EndpointID”: “c33482045bc4b8fb402009a11c795ce125bdb25d171a39986cdf3b51763f91cb”,
“MacAddress”: “02:42:ac:12:00:17”,
“IPv4Address”: “172.18.0.23/16”,
“IPv6Address”: “”
},
“41e4c956499ec95bcb816933aa16f67feaa879380596fbcafe50d33b8993eed2”: {
“Name”: “ee-global-db”,
“EndpointID”: “1112a083322853a663e1f6078ddf3974f9e32699f89a930c6c9eda23973628b3”,
“MacAddress”: “02:42:ac:12:00:10”,
“IPv4Address”: “172.18.0.16/16”,
“IPv6Address”: “”
},
“e680def19b6b50e61f0a98769800b0dc363253b3c9e06c22c661f4e384b9a61f”: {
“Name”: “mysitedotcom_nginx_1”,
“EndpointID”: “b3f2324665b491ce1e338dc106121d764862796a1d47650c403d63dd8dc69b7b”,
“MacAddress”: “02:42:ac:12:00:1d”,
“IPv4Address”: “172.18.0.29/16”,
“IPv6Address”: “”
},
“f38df54ab53a2dc9119fe74fbef5335431a31c4b4f5e3ac4de940790710e108c”: {
“Name”: “ee-global-redis”,
“EndpointID”: “40c5be4c282ca219b58fef0b7743623691ec12e7508c6ed86061ec8d04888680”,
“MacAddress”: “02:42:ac:12:00:11”,
“IPv4Address”: “172.18.0.17/16”,
“IPv6Address”: “”
}
},
“Options”: {},
“Labels”: {
“org.label-schema.vendor”: “EasyEngine”
}
}
]
(0.527s)
Debug: RETURN CODE: 0 (0.527s)
Debug: ----------------------- (0.527s)
Debug: ----------------------- (0.527s)
Debug: COMMAND: docker network inspect ee-global-frontend-network (0.528s)
Debug: STDOUT: [
{
“Name”: “ee-global-frontend-network”,
“Id”: “a8116ba5ddfa65944cb7679abac4e5511e5a1e045ab59f01a50094bf7dc28489”,
“Created”: “2018-11-02T11:45:57.038266677Z”,
“Scope”: “local”,
“Driver”: “bridge”,
“EnableIPv6”: false,
“IPAM”: {
“Driver”: “default”,
“Options”: {},
“Config”: [
{
“Subnet”: “172.19.0.0/16”,
“Gateway”: “172.19.0.1”
}
]
},
“Internal”: false,
“Attachable”: false,
“Ingress”: false,
“ConfigFrom”: {
“Network”: “”
},
“ConfigOnly”: false,
“Containers”: {
“5d87a6ca8416f54dd999c8fec8795f26fd17f812853c8ab7d5b12ad0339d8fe9”: {
“Name”: “ee-global-nginx-proxy”,
“EndpointID”: “30d459c312a937de8293712155ff04414d4067594752d7d878c192deaceccfdc”,
“MacAddress”: “02:42:ac:13:00:05”,
“IPv4Address”: “172.19.0.5/16”,
“IPv6Address”: “”
},
“e680def19b6b50e61f0a98769800b0dc363253b3c9e06c22c661f4e384b9a61f”: {
“Name”: “mysitedotcom_nginx_1”,
“EndpointID”: "2c69dfbf7c8346bd717b3c002b2adf794abc18614b30…


#2

@tamhas Can you recreate the site with ee site create <params> --debug and paste the whole(redaction is fine) output here?

Also before site creation, run:

ee log show

and also paste it’s output here.

If you feel a bit uncomfortable pasting your logs on public forum, you can also email them to ee@rtcamp.com with this issue link :slight_smile:


#3

Hi Kirtan, that is the whole, it just doesn’t show all of the sites. Is that not enough? I will redo anyway and mail you the whole thing


#4

@tamhas this has been fixed. Try updating to the latest stable version (ee cli update --stable --yes) and creating a new site.


#5

Thanks very much @mrrobot47 – the sites now install!


#6