Upgrade Nginx


#1

Have any of you succeeded on upgrading Nginx to latest version in servers running EE?

We are almost one year behind Nginx development, and I’d hate to abandon EE, but it is quickly becoming abandonware (despite how much I hate to admit it). :frowning:

Thanks in advance.


#2

Ubuntu default packages are also stuck on 1.10.3 :angry:


#3

I have tried to update packages with the last stable version but it doesn’t work at all.

So at the moment, I compile Nginx from sources with all additional modules I want (TLS 1.3; Brotli, Dynamic TLS support etc). I"m still working on a script to automate this part, and I will publish it on github soon. But you can find my script on https://git.virtubox.net/virtubox/ee


#4

@virtubox would you like to contribute to nginx build we maintain? I can connect you with @mriyam.tamuli .

https://build.opensuse.org/project/show/home:rtCamp:EasyEngine


#5

Yes, I have post my issues in the #nginx-build channel on easyengine slack, but I haven’t got any answer. But if I can help do not hesitate to tell me what I can do.


#6

I’ll use your job as a starting point, for sure.

The only thing I miss in your setup is mod_auth_pam, I use it in almost every server I run. Otherwise it is perfect for my needs. :slight_smile:

Thanks a million, bro!


#7

I have removed mod_auth_pam because there was issue when I have tried to compile nginx, but you should be able to add it


#8

It’s fine to remove mod_auth_pam. I don’t remember we are using it.

Here is Nginx modules list we use https://github.com/EasyEngine/nginx-build/wiki/Nginx-Modules-List


#9

I hope you don’t remove mod_auth_pam, because I use it in 100% of my servers. :slight_smile:


#10

May I know how do you use it?


#11

I’ve written a GUI for my customers to create new WPs, install SSL and monitoring RAM/Disk/Network usage.

To log in this tool customers need to authenticate with an user from Linux.

I dislike using .htpasswd in order to protect directories because it is one extra thing to manage; since mod_auth_pam allows me to keep SFTP and GUI passwords in sync, I prefer it.


#12

If you can compile nginx from source with auth_pam by editing settings in my script, it’s not a problem. I have only removed it because I do not use it and there was error when I have tried to use ./configure.


#13

For some reason your script didnt work for me even removing auth_pam. :frowning:

I was not able to try again since then.


#14

Split the script in several parts.

EDIT : I have just updated my script, work fine on Ubuntu 16.04 LTS :


#15

As I said in another thread, I successfully compiled Nginx using @virtubox’s script, after adding a development package:

apt-get install libpam0g-dev

Then, of course, I had to modify the script to clone the mod_auth_pam repository and to --add-module to the correct location of the cloned module.

So far, so good. :slight_smile:


#16

Ok great, I will add it in my bash script.


#17