Upgrade Headaches


#1

Hello,

I have tried to find a solution to the problem but am still getting the Migrate your database and it just hangs at 4. Below is the debug info.

Can anyone assist please? I miss my widget!

PHP 5.2.17
MYSQL 5.5.32
WordPress 3.5.2
BuddyPress 1.8
rtMedia 3.0.0
OS Linux
Imagick Not Installed
GD bundled (2.0.34 compatible)
[php.ini] post_max_size 128M
[php.ini] upload_max_filesize 128M
[php.ini] memory_limit 128M

Thanks,

Brian


#2

Hi,
Have you tried deactivating all the other plugins while migrating? Maybe some plugin is conflicting with the migrating json.


#3

Yes,

All plugins other than BuddyPress and rtMedia have been deactivated and it still hangs on 4/49.

Thanks,

Brian


#4

I fixed it! After having my host provider completely restore everything back to before the update, it works again!

I will wait until the whole thing blows over before I try to update again. Eventually I am sure that you will get it worked out and it will be awesome again, but until then I will steer clear…

BTW, you mean to tell me that if a member posts a porn pic on my site that because I am not the owner I cannot delete it? Simply wow…


#5

Now no more recent media is bring updated. Thanks a ton for breaking my site, developing in a jar and the awesome support…


#6

Please delete this whole thread


#7

You there 8 mile?


#8

Hi,
Apologies for the late reply as it was a weekend. Do you have a test site on which we could check the issue out for you?

And regarding the owner only delete issue, as told before this is an issue and not a desired functionality. We are working towards resolving issues one by one and this is also in the todo list. It should be resolved soon.


#9

@bmalandrone

As per your first comment, seems like you are using the older version of php 5.2.17.
I can suggest you to update the php version, you can take help from you hosting support team. And then check the migration, if still problem persist on your site, let us know.

Note:
Number of our users facing the issues, and when we cross checked their site and server configuration, the causes because of older php version, so when they updated php, everything is working fine.


#10

I am a little shocked that I actually got a response to this and apologize for being so frustrated with the plugin. I really would like to use it and loved it before, but now am having so many problems with the upgrade.

I do not have a test site, as this is a hosted account and have spent HOURS going over this with what I perceived as very little help (besides the one default answer).

So, I have managed to get it installed and the database migrated, though here are some suggestions that will perhaps help in new releases.

Error check! My db upgrade was not due to out dated PHP. It was because I did not have groups and forums enabled for buddypress. I use a different forum plugin. As soon as it was enabled it upgraded without a problem. Shouldn’t the upgrade script check for prerequisites and default to fail if not exist?

Second (which I am dealing with now is that I already have a media page that I created. Now is where it is failing.

I would be happy to provide login details so that you can take a look at it and give me some assistance and again, no offense and thanks for the help!


#11

Hi,
Are you sure the upgrade got stuck because of the above mentioned reasons? Were you able to successfully upgrade then?
We have actually done necessary checks during the migration.
Please provide the link to your website.


#12

And regarding the media page, did you create it using the shortcode?


#13

As soon as I enabled the groups and forums with the bbpress plugin the db upgrade finished and said successful, however now the [rtmedia_gallery] shortcode returns Media Gallery
Oops !! There’s no media found for the request !!

The site is mancaveland.com


#14

You can use [rtmedia_gallery global=“true”] to display all media. Check http://rtcamp.com/rtmedia/docs/common/shortcodes/gallery-shortcode/ for more details.


#15

Can you please assist? My site is screwed AGAIN!


#16
screwed AGAIN

What happened now?


#17