Updating sites to redis cache


#1

Hi there,

Is it possible to update a site from --wpfc to --wpredis with the command: sudo ee site update savvysites.co.za --wpfc --wpredis?

We get an error message: Please provide valid options combination for site update

If not, how would we gou about doing this?

Regards Francois Wessels


#2

@francois_wessels

You just need to provide options to which you have to upgrade.

so to update to wpredis use

ee site update savvysites.co.za --wpredis


#3

You basically want to do:

sudo ee site update savvysites.co.za --wpredis

#4

Hey guys,

Sorry, my mistake. Used the command as suggested and it worked flawlessly.

Cheers franwess


#5

I am having a similar issue updating a base --wp to --wpredis.

ee site update mydomain.com --wpredis can not update wp wpredis to wp wpredis

I believe the command is correct but it will not update to the redis option. any ideas?


#6

EE says the site is wpredis alredy.

What’s the output for ee site info domain.com?


#7

it could not have been ready with wpredis as I had purged the redis stack… I reinstalled the redis stack and still the same issue.

oddly it says that it is wp wpredis, but I always setup with --wp --php7 as the only flags, never setup with wpredis as many are on small memory machines.


#8

I’d try:

ee site update domain.com --wp
ee site update domain.com --wpredis

#9