Updated to 2.2.1 and I got this error


#1

After updating when I try and enter the dashboard I get this error:

Fatal error: Call to a member function get() on a non-object in /home/XXXXX/public_html/wp-includes/query.php on line 27

What do you think could be the problem?


#2

Yeah, I got the same error when updating from 2.1.5 to 2.2.1 and the latest 2.2.2.
Going back to 2.1.5 solves the problem.

The error occurs with me only when trying to get back into the dashboard. Front side of the website works without any problems.


#3

Hi All,

We have release a minor update version 2.2.3. This has a upgrade script which is better than previous version.

If you are still facing issues, please email to admin@rtcamp.com. We will check out your site and help you upgrade for free.

The problem is none of site to which we have access is throwing above error. So its hard to debug something without seeing it.


#4

I just sent you an email… Thank you so much for the help!!


#5

Thanks. Gagandeep is looking into it.


#6

You guys are NINJAS!!!.. Thanks for fixing it!!!


#7

Thats aweme to hear your problem is fixed. Is there a simple solution for this? Or do I need to pm login details?


#8

Never mind!
Update to 2.2.5 solved the problem!

Keep up the good work!


#9

@vulneratum

Thanks again. :slight_smile:

@dutchman

Glad to know your problem is solved. :slight_smile:


#10