Update to EE 3.8


#1

I try to update EasyEngine to 3.8. When I try to update I recieve this error.

ee update

Downloading update script Unable to download file, /tmp/eeupdate20180529-085329

Can I fix it?


#2

You can use:

sudo -i

then

wget -qO ee https://raw.githubusercontent.com/EasyEngine/easyengine/master/install && bash ee

#3

@EyesX The ee stack upgrade --nginx command also does not work.

At the end, it says it updated the NGINX, but when I run the nginx -v command it continues the same version.


#4

I just fresh installed a new VPS, and Nginx is 1.14.0.

Try rebooting your server and repeating the tests.

However, I’ll stick to compiling my own Nginx (props to @virtubox) because I like AIO Threads (not included in this package) and Brotli support.


#5

I followed @EyesX commands to upgrade EE and my Nginx was upgraded with the ee stack upgrade --nginx command successfully.


#6

@portofacil @mdotk I rebooted the server but it did not work.

I upgraded the server as well.

Note: My server is a Debian version 8, PHP 7.

But now, when trying to update again, the answer is the message below:

Oops Something went wrong!! Check logs for reason tail /var/log/ee/ee.log & Try Again!!!


#7

Well… What did you find in that particular log file?


#8

@portofacil root@:~# tail /var/log/ee/ee.log Ign http://packages.dotdeb.org jessie InRelease Ign http://mirrors.digitalocean.com jessie InRelease Get:2 http://sfo1.mirrors.digitalocean.com jessie/main amd64 Packages [5,715 B] Get:3 http://download.opensuse.org Release.gpg [481 B] Hit http://mirrors.digitalocean.com jessie-updates InRelease Ign http://packages.dotdeb.org jessie/all amd64 Packages/DiffIndex W: GPG error: http://packages.dotdeb.org jessie InRelease: The following signatu res couldn’t be verified because the public key is not available: NO_PUBKEY E9C7 4FEEA2098A6E E: Release file for http://mirrors.digitalocean.com/debian/dists/jessie-updates/ InRelease is expired (invalid since 3h 50min 55s). Updates for this repository w ill not be applied. 2018-05-30 00:13:40,118 (INFO) ee : Oops Something went wrong!! 2018-05-30 00:13:40,118 (ERROR) ee : Check logs for reason tail /var/log/ee/ee. log & Try Again!!!


#10

Hello @robsonwp, Please run

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv  4FEEA2098A6E

Then try ee stack upgrade --nginx again.


#11

It worked. :wink:

Thank you so much @mriyam.tamuli


#12

Just managed to update ee to 3.8 with help from @EyesX post above.

Now while trying to update Nginx from 1.10.3 to 1.14 it gives me the following error:

Oops Something went wrong!! Check logs for reason tail /var/log/ee/ee.log & Try Again!!!

And the contents of ee.log are:

root@webmail:~# tail /var/log/ee/ee.log Ign:21 http://ppa.launchpad.net/brianmercer/nginx/ubuntu xenial/main Translation-en Err:22 http://ppa.launchpad.net/rtcamp/nginx/ubuntu xenial/main amd64 Packages 404 Not Found Ign:23 http://ppa.launchpad.net/rtcamp/nginx/ubuntu xenial/main all Packages Ign:24 http://ppa.launchpad.net/rtcamp/nginx/ubuntu xenial/main Translation-en_US Ign:25 http://ppa.launchpad.net/rtcamp/nginx/ubuntu xenial/main Translation-en Fetched 323 kB in 9s (35.3 kB/s) Reading package lists… 2018-05-30 06:13:20,592 (INFO) ee : Oops Something went wrong!! 2018-05-30 06:13:20,592 (ERROR) ee : Check logs for reason tail /var/log/ee/ee.log & Try Again!!! root@webmail:~#

Can someone guide me please?

Thanks.

— update —

Managed to solve the issue after searching in the community. Here’s the solution from @unculturedswine that worked for me:

sudo apt-get -o Dpkg::Options::="–force-confold" install nginx-custom nginx-ee

Thank you.


#13

I tried to update to 3.8.1

The following packages have unmet dependencies: nginx-custom : Depends: nginx-common (= 1.14.0-1ppa~stable) but 1.10.3-10ppa~stable is to be installed nginx-ee : Depends: nginx-common (= 1.14.0-1ppa~stable) but 1.10.3-10ppa~stable is to be installed E: Unable to correct problems, you have held broken packages. 2018-05-30 08:07:13,602 (INFO) ee : e[94me[91mOops Something went wrong!!e[0m 2018-05-30 08:07:13,603 (ERROR) ee : e[91mCheck logs for reason tail /var/log/ee/ee.log & Try Again!!!e[0m 2018-05-30 08:09:42,794 (DEBUG) ee : logging initialized for ‘ee’ using LoggingLogHandler 2018-05-30 08:09:43,009 (DEBUG) ee : [’/usr/local/bin/ee’, ‘update’] 2018-05-30 08:09:43,010 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7f5f00e09b00> 2018-05-30 08:09:43,011 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.update.EEUpdateController object at 0x7f5f00e09e48> 2018-05-30 08:09:43,013 (INFO) ee : Initializing EasyEngine Database 2018-05-30 08:09:43,015 (INFO) ee : e[94mDownloading update script e[0m 2018-05-30 08:09:45,378 (INFO) ee : e[94m[e[0mDonee[94m]e[0m 2018-05-30 08:09:45,378 (INFO) ee : e[94mupdating EasyEngine, please wait…e[0m 2018-05-30 08:09:50,206 (DEBUG) ee : logging initialized for ‘ee’ using LoggingLogHandler 2018-05-30 08:09:50,428 (DEBUG) ee : [’/usr/local/bin/ee’, ‘-v’] 2018-05-30 08:09:50,428 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7f6bca021b00>


#14

I have this as well. Did you ever found a solution for your problem?


#15

Nope :frowning:


#16

Pity :confused: But you are still running it?

I used VirtuBox script to update nginx, did you? Not that it fixed the original problem


#17

yes, im using it. im waiting for v4 to reinstall the vps :slight_smile:


#18