Update installation with cache?

Hi.

How update my installation with cache?

Example: ee site reload example.com --cache ???

I can’t find the documentation to activate.

Thank you for support

1 Like

it can only be created 1 time, you will not be able to use the update command. update not working

Yeah the update system at the moment only supports a limited number of commands; https://easyengine.io/commands/site/update

You are better off backing up your website with a free plugin like Updraftplus, then recreate your site with the cache flag (and ssl, wildcard etc if you’re already using SSL, may as well get it all done in one go. Although the update command does support --ssl and --wildcard, so if you’re not using SSL right now you can always add it later on.)

Updraft is pretty easy to use, it’ll backup your entire site in one go. Simply click on “Backup Now” and wait for the process to finish. Then download all the zip files (database, themes, uploads, plugins, others, and the text log) to a folder on your computer (or remote upload it to Google Drive, Dropbox or whatever you want. Either way good to have it stored in more than 1 location)

To make things a lot easier:

Before backing up via Updraft, first install the two plugins I’ve listed below, because easyengine installs them when you use the --cache flag. If you don’t install them first before backing up, you’ll need to install them manually after you restore. Don’t activate the plugins before you make your backup, just have them installed so they will be there for you when you restore on your new site.

Note:

When you create your website again ee will give you different credentials for wp-admin, which means when you restore your backup, you will need to log in with the username and password that you are currently using on your existing site and you won’t be able to log in with the new credentials that ee just gave you when you re-created your site. To avoid this and make everything seamless, you want to create your new website with same user/password that you’re already using. So when you’re creating your new site, after all the other flags you use (eg --cache etc) insert the flags --admin-email=yourcurrentadminemail@yourdomain.com --admin-user=yourcurrentusername --admin-pass=yourcurrentpassword and this way when you restore your backup you simply log in with the credentials that you’ve already been using this whole time. If you need to find out what the user/pass/admin email is on your existing site, just run ee site info yourdomain.com

Now on your freshly re-created website, install & activate the updraftplus plugin and go to the Updraft page. Click on “upload backup files” and then drag and drop all of the ZIP files and the text log from the backup you just made. You’ll then see the backup come up under the “Existing backups” tab. Click restore and tick all the boxes (restore database, themes, uploads, plugins, others). It will then verify the restore package, and ask you to click restore 1 more time to begin the process. It should only take a few seconds to complete.

Once you’ve restored your Updraft backup, log in to your website and now you enable the nginx-helper and wp-redis plugins. And then under Settings > Nginx Helper you should see that the caching method is set to ‘Redis Cache’. All the settings will already be pre-populated for you via easyengine, the config boxes will actually be greyed out so you can’t override the settings (this is how you’ll know that everything has worked perfectly). Hit save, then click purge entire cache and that’s pretty much it.

All done.

**The two plugins to install (but not activate) before you backup:**


3 Likes

When I do this procedure quoted above I get HTTP ERROR 500, I have tried several times, with different domains, using ee site create juliocorrea.com --type=wp --ssl=le --cache and then using UPDRAFTPLUS. I will quit. :frowning:

That is strange, I tried the steps myself on a separate domain before I posted that to make sure it worked. Try backing up with updraft without those 2 plugins installed. Re-create your site (with the cache flag), restore the backup and then install the two plugins. Did your site originally have SSL enabled before you created your updraft backup?

Some yes and others no, the ones I had not do without the ssl indicator, the ones I already had I do with.

I’m pretty sure updraft considers it a new site (and get you to buy a plugin) if your backup is from a http site to a https. So for your websites that are not already SSL, backup and re-create the site with the --cache flag only, then restore and install the plugins, and then use the site update command to enable SSL.

Maybe I have expressed myself poorly, I’m from Brazil, I’m sorry, the sites that are without SSL I recreated the site without SSL. And the sites that are SSL I recreated with SSL

Then that is very strange that the backup/restore did not work. On one of the sites without SSL can you test backing up without installing the nginx-helper and wp-redis plugins, re-create the site with cache flag but without ssl flag. And then restore, and once restored install the two plugins. If it works at that point, then use the site update command to enable SSL on the website (if needed)

So, the sites come to work, for about 3 hours, then suddenly gave error in all sites, both ssl and without ssl.
I’m going to destroy the droplet and try to recreate everything again. But ee4 has given me several mistakes, it does not seem ready yet.

1 Like

I got success on migrating my website, but both were wildcards ssl.

What does not seem to work is the caching. Everytime someone visits the page, a new cache is recreated.
I can check this because I enabled the html comment.
Cached using Nginx-Helper on 2019-11-07 11:08:12. It took 78 queries executed in 0,757 seconds.
Every visit generates a new timestamp. :confused:

Any help on that?