Unable to view web packages?


#1

Hi,

So I have everything setup and working, however, when I try accessing web packages such as phpMyAdmin etc using my domain name I run into an issue with the self signed SSL certificate being used over my SSL on my domain, therefore, I get an error:

Your connection is not private

You cannot visit domain.com right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.

However, if I just use the server IP it work by using the default self signed SSL.

I would ideally want to use my domain name with my signed SSL, but don’t wish to change the 22222 config in sites-available unless I have to incase someone accesses the web packages using the IP.

Ideas?


#2

If you have activate HSTS on a domain, that mean it must have a valid SSL certificate during a period defined with the HSTS. So your browser will block any access to a website already visited with the HSTS and with a invalid certificate. you should have access to :22222 using another browser, or by using the IP. But it doesn’t come from EE


#3

Yes you are right I can use IP and tried from another server without HTTPS and can use the domain:22222 fine.

What I was wondering can I use my SSL to work with the :22222 by just changing the server block. obviously then the self signed one would not work and you wouldn’t be able to login using the IP.


#4

Yes you just have to edit the nginx conf for the folder 22222 and to use your domain certificate with it. But the security is the same with a self-signed than with a valid certificate.


#5