Unable to Upload Media


#1

Greetings! Nobody (users or admin) are able to upload media. I've tried changing to the default WP theme thinking maybe my theme (Custom Community) was the issue, still didn't work... changed back. Thinking permissions may be an issue, I reset all user role capabilities.

When clicking on the media button, a dialog appears where a file can be selected, after selecting a file it displays the file name and 0% but just hangs and never progresses. When selecting media from the drop-down in the admin menu-bar, I get a "page not found".

the url is: http://williston.resolutionsbydesign.com/ if you would like to come take a look.

Below is the debug information. Thanks

Debug info

PHP 5.5.0
MYSQL 5.1.70
WordPress 3.5.2
BuddyPress 1.8
rtMedia 3.0.0
OS Linux
Imagick ImageMagick 6.8.3-9 2013-04-24 Q16 www.imagemagick.org
GD bundled (2.1.0 compatible)
[php.ini] post_max_size 8M
[php.ini] upload_max_filesize 2M
[php.ini] memory_limit 128M


#2

I’m having the exact same problem. When using the test site it works, it stays at 0% until you press ‘Post Update’. The difference is that on my OWN site, when I submit it, nothing happens and only the text gets uploaded.

Does anyone know what would cause this?


#3

update I was able to temporarily fix the “Page not found” error by putting the permalinks into “Default” (no other setting seemed to work).

When trying to upload media, the status then went to 100%, however the image is not displayed anywhere than I can find. (Also Buddypress doesn’t like permalinks being in default mode). So I changed permalinks setting back to “Post name” until this is resolved.


#4

It has mysteriously started working… shrug


#5

@madnhain - Glad to know the flushing of permalinks resolved your issue.

@Mick C - Have you tried deactivating the other plugins and checking.


#6

@Joshua Abenazer thanks for your reply, I don’t actually have any other plugins enabled at the moment other than Buddypress and Buddypress Media, and I’ve tried with just the default Buddypress theme. :frowning:


#7

@Mike C - Are you using the latest version of rtMedia? Could you trying re-saving your permalinks and check?


#8