Unable To Update WordPress Permalink For site.com


#1

Hey There,

Recently I restored a server from an image on a new server (Digital Ocean style). When I went to create a new site on the server I got this notice. I’ve never encountered this error before and I’m not sure what it’s from. I tried reloading nginx and rebooting the server to no avail. Any ideas on what might be causing the error?


#2

As I've gone through the process of setting up on a new server I realized that I whitelisted an IP address. Could this be something that's conflicting with the new server on a new IP?


#3

So it looks like this has nothing to do with it. I've tried a couple of things to try and fix things: 1. ee system install (to recreate things) 2. manually changing the IP to whitelist

When I do an ee site create domain.com -wp what happens is that it goes through the whole process and gets to the permalink part and then fails. I get an email with my wp login credentials but when I try to access the domain I get redirected to another install on the server. It looks like everything gets set up correctly, I get an nginx conf file, I see the folder on the server and I can't figure out what might be causing this one issue.


#4

ee system install may not work on existing server.

Did you get any error during site creation process? Please copy/paste error here.

Additionally, you may attach log files from folder /var/log/easyengine/ here.


#5

Here's the last entry in the error log from an attempt I tried today. It looks like it doesn't like me running the site create as root. I tried with a different username and it didn't work either because I installed ee as root. I could rebuild the entire server under a different username if you think that's best. Please note the error log has been scrubbed for security. The interesting thing is that it hasn't had a problem with me running as root up until now. All this server is, is an exact replica of an existing server but with backups set up (on Digital Ocean). Not sure why all of a sudden it won't let me do anything.

Thanks for any direction.

e[34mEasyEngine (ee) Execution Started [Sun Mar 30 13:23:51 EDT 2014]e[0m e[34mEasyEngine (ee) Command: /usr/local/sbin/ee site create afwefadsfwe --wpfce[0m SITENAMECHECK = afwefewfadsfweawef EESITECREATE = --wp WPCACHEOPTION = --wpfc NETWORKACTIVATE =
WPSUBDOMAINS =
NGINXCONF = wp/wpfc.conf e[34mCreating adsfawefawefasd, Please Wait...e[0m e[34mCreating Symbolic Link For asdfadsfasdfdsaf[0m e[34mCreating htdocs & logs Directorye[0m e[34mCreating Symbolic Link For Logse[0m e[34mDownloading WordPress, Please Wait...e[0m MySQL Database Username adfwefe = 32 e[31mERROR 1470 (HY000): awefaefefefaw Is Too Long For MySQL Usernamee[0m WPDBNAME = adfawef WPDBUSER = adfwef WPDBPASS = aadfwefwadfawer e[34mSetting Up WordPress, Please Wait...e[0m Success: WordPress installed successfully. e[34mUpdating WordPress Permalink, Please Wait...e[0m Error: YIKES! It looks like you're running this as root. You probably meant to run this as the user that your WordPress install exists under.

If you REALLY mean to run this as root, we won't stop you, but just bear in mind that any code on this site will then have full control of your server, making it quite DANGEROUS.

If you'd like to continue as root, please run this again, adding this flag: --allow-root

If you'd like to run it as the user that this site is under, you can run the following to become the respective user:

sudo -u USER -i -- wp ...  

[ Sun Mar 30 13:24:00 EDT 2014 ] e[31m Unable To Update WordPress Permalink For adsfasdfasdfd e[0m


#6

Hello Jgiroux,

Its seems like you are using old version of easyengine. Recently wp-cli don't allow to run the command as a root user without --allow-root flag which is fixed in easyengine version 1.1.4

Please check your easyengine version by using following command ee version

You can update the easyengine by using ee update command


#7

Hey Mitesh,

Thank you for your response. All servers are at 1.2.2 for ee version and no update is available. If there's no other way to resolve the issue without sending you in to snoop, I will just rebuild the servers from scratch. My bigger worry is that if there was ever an issue that required me to restore a server from backup, I would lose the ability to add new sites to my servers.

I'm not sure what else I can do on my end to fix this without uninstalling ee and starting over.

Any thoughts?


#8

Hello Jgiroux,

The error you face is related to the wp-cli, wp-cli failed to update the wordpress permalink Ref: https://github.com/rtCamp/easyengine/blob/stable/usr/local/sbin/easyengine#L1032

Can you give me the output of following commands

  
wp --info --allow-root  

#9

PHP binary: /usr/bin/php5 PHP version: 5.5.10-1+deb.sury.org~precise+1 php.ini used: /etc/php5/cli/php.ini WP-CLI root dir: /usr/share/easyengine/wp-cli/vendor/wp-cli/wp-cli WP-CLI global config:
WP-CLI project config:
WP-CLI version: 0.14.0


#10

Hello Jgiroux,

Sorry for the late reply, Please provide me the output of following commands

lsb_release -a

Please run the following command with root user not sudo whoami && ee site create example.com --wp

Please give me the output as well as log files located at /var/log/easyengine/install.log


#11

@jgiroux

As this is almost a year old topic, we are closing this. Please create a new topic if you face any issue.


#12