Unable to run apt-get install problem


#1
# ee site create phpsitehhvm.test.com --mysql --hhvm --pagespeed
Adding repository for HHVM, please wait ...
Updating apt-cache, please wait ...
Installing packages, please wait ...
Unable to run apt-get install

I even run " apt-get update" as suggested on other thread, but still can’t add new site.

What could be the problem?


#2

I am having the same problem with all existing VPS and new VPS since last ee update!

Not working in some instances… ee stack install --mysql worked

…BUT…

ee stack install came up with error…


#3

Opz, I thought ee is very stable, seems not :frowning:


#4

Honestly ee is great and stable and saves hours of time!


#5

But for me, first time user and experience this problem right away :frowning: No idea how to solve :smiley:


#6

I understand, its difficult, but honestly if you do what ee does manually, by yourself…

I know its frustrating, I hope it gets resolved quickly too…

If you want the basic web package install mysql, nginx and php with commands below, all seem working ok!

UPDATE:

found working: ee stack install --mysql ee stack install --nginx ee stack install --php


#7

So this command is required for first time user? I thought the first command will install all needed package.


#8

Well ‘ee stack install’ normally installs all these, but until we see that working you could, after doing a …

wget -qO ee rt.cx/ee && sudo bash ee # install easy-engine

…use the three separate commands ie. ‘ee stack install --mysql’ then ‘ee stack install --nginx’ then finally ‘ee stack install --php’ and still have saved hours of time in setting up!

then … http://docs.rtcamp.com/easyengine/commands/site/create#WordPressSite – for example


#9

@RoldanLT

can you share your logs ?

tail -n200 /var/log/ee/ee.log


#10

Sorry but I already delete the Node/Vps.


#11

Yes of course, this is a fresh install on VPS after running ee stack install…

http://pastebin.com/bhxSNcgq

… hhvm causing a problem, after recent addition to install stack?

v 3.1.0 - April 16, 2015

  • Added HHVM support #199
  • Added Pagespeed support #473
  • EasyEngine log command now suppots more subcommand #448
  • Before stack purge or remove, EasyEngine now asks confirmation #485
  • Minor fixes and improvements

This was about when problem started for me…


#12

@adamess

Thanks for the logs.

We have tested on fresh server and did not see auch problem.

Will investigate into the issue and we will be fixing this in very next minor release.


#13

I really appreciate that thank you, I really do love your ee with a passion it really saves me hours of time!

Thank you


#14

Could I also add a little something to the list of things to things to investigate…

After purging admin tools and reinstalling, also any command which could check and install nginx, or even to create a website, a duplicate entry of ‘worker_rlimit_nofile 100000;’ gets added to ‘/etc/nginx/nginx.conf’ … I have to remove the duplicate before ‘service nginx restart’

Thank you :smiley:


#15

I don’t think EE was designed to be easy for any person, despite their knowledge (or lack of) in Linux.

You should run apt-get update by hand. If there is some repository issue it will be exposed. It’s kinda common (not to EE but to Ubuntu as a general) that sometimes someone forgets to properly sign a package, or something.

If that’s the case, and I bet it is, the solution have been mentioned several times in this forum. One of them can be found here:

http://community.easyengine.io/t/unable-to-run-apt-get-install/4260/


#16

@janiosarmento Thank you for your contribution!

Here was me thinking they called it easy engine for the reason that it made things easy! …oh hang on …it is easy!

I remember the beginnings of linux, and learning to install it with my friend who introduced me to it at university when linux was a base of 5 x 3.5inch floppy disks, and when you setup your monitor config while installing xwindows that took 2 days to download and it was indeed possible to drive your monitor too fast and break it!

Linus Torvalds was the creator, he’s a revision control Git isn’t he… thank you Linus!

Now if I wanted to take a look at the ee logs and then fix things up a little I might guess a lack of a repository and/or sig key…

…if I had Debian wheezy I might try:

sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0x5a16e7281be7a449
echo deb http://dl.hhvm.com/debian wheezy main | sudo tee /etc/apt/sources.list.d/hhvm.list
sudo apt-get update
sudo apt-get install hhvm

…or perhaps on Ubuntu 14.04 I might try:

sudo apt-get install software-properties-common

sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0x5a16e7281be7a449
sudo add-apt-repository 'deb http://dl.hhvm.com/ubuntu trusty main'
sudo apt-get update
sudo apt-get install hhvm

perhaps go as far as…

sudo /usr/share/hhvm/install_fastcgi.sh

sudo /usr/bin/update-alternatives --install /usr/bin/php php /usr/bin/hhvm 60

sudo update-rc.d hhvm defaults

configure Nginx

Restart HHVM

replace php processing block in virtual hosts (hhvm and php redundancy backup…) -->

location ~ \.(hh|php)$ {
  proxy_intercept_errors on;
  error_page 502 = @fpm;

  try_files $uri /index.php;
  include fastcgi_params;
  fastcgi_pass unix:/var/run/hhvm/hhvm.sock;
  fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
  fastcgi_index index.php;
}

location @fpm {
  try_files $uri /index.php;
  include fastcgi_params;
  fastcgi_pass unix:/var/run/php5-fpm.sock;
  fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
  fastcgi_index index.php;
}

Add Monit for some monitoring of a relatively untested outside of facebook system…

…optionally…

Add Redis for some improved object caching with MySQL…

Perhaps…

…and then by magic perhaps it will work?

…have I inadvertently broken something else in the process, or forgotten something…

But I am busy and I like ee and how easy it is, how it looks after itself, I trust to let the ee guys do what they do best and make everything work along with ee beautifully and easily…

Note the difference between your posted apt-key and the one I posted here…


#17

Our goal is to make life easy for everyone but yes, person who knows linux or did server administration before, will always have upper hand.

Still, we are trying way to improve error handling so if anything goes wrong, it will “easy” to understand what went wrong (hopefully for anybody).

We are planning to handle some package updated using ee stack update command we are planning to introduce soon. That way, atleast ee related packages will be updated smoothly.

We are also discussing package related issues, not related to EE, here - https://github.com/rtCamp/easyengine/issues/495

Please pass your suggestions. We really want to make life easy for all of us. :slight_smile:


#18

Already tried that before posting this thread.


#19

@RoldanLT If you’re a patient person just wait for this to be fixed, its worth it I believe, just one tiny cog crashing the works…


#20

@RoldanLT

@adamess

@janiosarmento

checkout EasyEngine v3.1.3 it fixes these GPG key problems