Unable to move file error showing


#1

I am having this error upon creating the ee site create example.com --wpfc Unable to move file from /var/www… to /var/www/… how to fix this?


#2

@rnovino

please give us following information

lsb_release -a

ee -v


#3

@harshadyeola ----------

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.1 LTS
Release:        14.04
Codename:       trusty
# ee -v
EasyEngine v3.0.2
Copyright (c) 2015 rtCamp Solutions Pvt. Ltd.

#4

@rnovino

could you provide some more info ,

tail /var/log/ee/ee.log


#5

@harshadyeola harshadyeola

tail /var/log/ee/ee.log

2015-02-17 17:32:30,009 (ERROR) ee : Unable to move file from /var/www/.../htdocs/wp              -config.php to /var/www/....net
2015-02-17 17:39:39,431 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2015-02-17 17:39:40,177 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseCon              troller object at 0x7f648a556eb8>
2015-02-17 17:39:40,178 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteControl              ler object at 0x7f648a56b2e8>
2015-02-17 17:39:40,179 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteDeleteC              ontroller object at 0x7f648a56b550>
2015-02-17 17:39:46,700 (DEBUG) ee : Removing Nginx configuration
2015-02-17 17:39:46,751 (DEBUG) ee : EEGit: git commit at /etc/nginx
2015-02-17 17:39:46,860 (ERROR) ee : xxxxxx.net does not exist in database
2015-02-17 17:42:17,529 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2015-02-17 17:42:17,770 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseCon              troller object at 0x7f30eea1ae80>

#6

@rnovino

Could you please give me access to your system, so that i can debug the issue

here is my public key

ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQClfOuNzr/JinPqYtHbYCbqfmWhCeRoozeX8EyN3APE1tzWPIKvAkCeTQ26aybgUsCFodrXmEAfG7T/4HzmXUlEUuE5wKT8CEGzD8nkmqhGfpj6WLcfJXNwBTMKiEnocxvRusH/YVZSgGaavxCxAyn5f9nrh9sl+xMv34mlEVf0sGcdkSOvVcmRLVTJFWe/vlcfhs3t6OT8CzVA/J60kWsb7AcODHpTsy4dvJLU8Hxr2l9aaht7Deq940IvQ/tHf3YUBJ16R1zj63hFbixZwBXIIKXTfM6OxXEfxTFwauKMRPK2ULqLTwrEWpNQpMVFkDgODZzOXEqhj3JKR4CWzgb1 harshad.yeola@rtcamp.com


#7

@harshadyeola I have added you up


#8

@rnovino

Plz share your system public ip or domain name so that ia can access it.


#9

its pinoyscreencast.net


#10

I’m having the same issue. This is an example fake site install. I’m thinking it must be permissions, but can’t figure it out. I’m trying to set up with remote mysql as well.

ee site create testsite222.com --wp Setting up NGINX configuration [Done] Setting up webroot [Done] Downloading Wordpress [Done] Enter the MySQL database user name [testsite222_com]: Enter the MySQL database password [n9WhzsSxboyJOjd]: Setting up database [Done] Enter the WordPress table prefix [wp_]: Unable to move file from /var/www/testsite222.com/htdocs/wp-config.php to /var/www/testsite222.com

2015-02-17 04:48:41,872 (DEBUG) ee : Setting apt_packages variable for Nginx 2015-02-17 04:48:42,346 (DEBUG) ee : Setting apt_packages variable for PHP 2015-02-17 04:48:42,807 (DEBUG) ee : Setting apt_packages variable for MySQL 2015-02-17 04:48:42,807 (DEBUG) ee : Running command: mysqladmin ping 2015-02-17 04:48:42,824 (DEBUG) ee : Setting apt_packages variable for Postfix 2015-02-17 04:48:43,309 (DEBUG) ee : Setting packages variable for WP-CLI 2015-02-17 04:48:43,309 (DEBUG) ee : Running command: which wp 2015-02-17 04:48:43,312 (INFO) ee : Setting up NGINX configuration 2015-02-17 04:48:43,330 (INFO) ee : [Done] 2015-02-17 04:48:43,330 (DEBUG) ee : Destination: /etc/nginx/sites-enabled/testsite222.com exists 2015-02-17 04:48:43,330 (INFO) ee : Setting up webroot 2015-02-17 04:48:43,331 (INFO) ee : [Done] 2015-02-17 04:48:43,331 (INFO) ee : Downloading Wordpress 2015-02-17 04:48:43,331 (DEBUG) ee : Running command: wp --allow-root core download 2015-02-17 04:48:43,997 (INFO) ee : [Done] 2015-02-17 04:48:46,027 (INFO) ee : Setting up database 2015-02-17 04:48:46,027 (DEBUG) ee : Creating databse testsite222_com 2015-02-17 04:48:46,050 (DEBUG) ee : Executing MySQL statement: create database testsite222_com 2015-02-17 04:48:46,058 (DEBUG) ee : Creating user testsite222_com 2015-02-17 04:48:46,058 (DEBUG) ee : create user testsite222_com@% identified by ‘’ 2015-02-17 04:48:46,069 (DEBUG) ee : Setting up user privileges 2015-02-17 04:48:46,072 (DEBUG) ee : Executing MySQL statement: grant all privileges on testsite222_com.* to testsite222_com@% 2015-02-17 04:48:46,079 (INFO) ee : [Done] 2015-02-17 04:48:47,371 (DEBUG) ee : Setting up wp-config file 2015-02-17 04:48:47,371 (DEBUG) ee : Generating wp-config for WordPress Single site 2015-02-17 04:48:47,372 (DEBUG) ee : bash -c "php /usr/bin/wp --allow-root core config --dbname=testsite222_com --dbprefix=wp_ --dbuser=testsite222_com --dbpass= --extra-php<<PHP

define(‘WP_DEBUG’, false); PHP" 2015-02-17 04:48:47,436 (DEBUG) ee : ERROR 1045 (28000): Access denied for user ‘testsite222_com’@‘localhost’ (using password: YES) 2015-02-17 04:48:47,436 (DEBUG) ee : Moving file from /var/www/testsite222.com/htdocs/wp-config.php to /var/www/testsite222.com 2015-02-17 04:48:47,436 (DEBUG) ee : [Errno 2] No such file or directory: ‘/var/www/testsite222.com/htdocs/wp-config.php’ 2015-02-17 04:48:47,437 (ERROR) ee : Unable to move file from /var/www/testsite222.com/htdocs/wp-config.php to /var/www/testsite222.com 2015-02-17 04:48:54,584 (DEBUG) ee : logging initialized for ‘ee’ using LoggingLogHandler 2015-02-17 04:48:54,783 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7f27d6afc0f0> 2015-02-17 04:48:54,785 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteController object at 0x7f27d6afc400> 2015-02-17 04:48:54,786 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteDeleteController object at 0x7f27d6afc7b8> 2015-02-17 04:48:59,101 (DEBUG) ee : Removing Nginx configuration 2015-02-17 04:48:59,111 (ERROR) ee : testsite222.com does not exist in database


#11

Here’s the other info you requested from rnovino from my server. This is a fresh install as well. I have another server running the same that I upgraded to 3.02 and I’m not having this issue.

lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 14.04.1 LTS
Release:	14.04
Codename:	trusty
root@press-nginx-a-01:/var# 
root@press-nginx-a-01:/var# ee -v
EasyEngine v3.0.2
Copyright (c) 2015 rtCamp Solutions Pvt. Ltd. 

This might be easier to read than the first post.

2015-02-17 04:48:41,872 (DEBUG) ee : Setting apt_packages variable for Nginx
2015-02-17 04:48:42,346 (DEBUG) ee : Setting apt_packages variable for PHP
2015-02-17 04:48:42,807 (DEBUG) ee : Setting apt_packages variable for MySQL
2015-02-17 04:48:42,807 (DEBUG) ee : Running command: mysqladmin ping
2015-02-17 04:48:42,824 (DEBUG) ee : Setting apt_packages variable for Postfix
2015-02-17 04:48:43,309 (DEBUG) ee : Setting packages variable for WP-CLI
2015-02-17 04:48:43,309 (DEBUG) ee : Running command: which wp
2015-02-17 04:48:43,312 (INFO) ee : Setting up NGINX configuration 	
2015-02-17 04:48:43,330 (INFO) ee : [Done]
2015-02-17 04:48:43,330 (DEBUG) ee : Destination: /etc/nginx/sites-enabled/testsite222.com exists
2015-02-17 04:48:43,330 (INFO) ee : Setting up webroot 		
2015-02-17 04:48:43,331 (INFO) ee : [Done]
2015-02-17 04:48:43,331 (INFO) ee : Downloading Wordpress 		
2015-02-17 04:48:43,331 (DEBUG) ee : Running command: wp --allow-root core download
2015-02-17 04:48:43,997 (INFO) ee : [Done]
2015-02-17 04:48:46,027 (INFO) ee : Setting up database		
2015-02-17 04:48:46,027 (DEBUG) ee : Creating databse testsite222_com
2015-02-17 04:48:46,050 (DEBUG) ee : Executing MySQL statement: create database `testsite222_com`
2015-02-17 04:48:46,058 (DEBUG) ee : Creating user testsite222_com
2015-02-17 04:48:46,058 (DEBUG) ee : create user `testsite222_com`@`%` identified by ''
2015-02-17 04:48:46,069 (DEBUG) ee : Setting up user privileges
2015-02-17 04:48:46,072 (DEBUG) ee : Executing MySQL statement: grant all privileges on `testsite222_com`.* to `testsite222_com`@`%`
2015-02-17 04:48:46,079 (INFO) ee : [Done]
2015-02-17 04:48:47,371 (DEBUG) ee : Setting up wp-config file
2015-02-17 04:48:47,371 (DEBUG) ee : Generating wp-config for WordPress Single site
2015-02-17 04:48:47,372 (DEBUG) ee : bash -c "php /usr/bin/wp --allow-root core config --dbname=testsite222_com --dbprefix=wp_ --dbuser=testsite222_com --dbpass= --extra-php<<PHP 
 

define('WP_DEBUG', false);
PHP"
2015-02-17 04:48:47,436 (DEBUG) ee : ERROR 1045 (28000): Access denied for user 'testsite222_com'@'localhost' (using password: YES)
2015-02-17 04:48:47,436 (DEBUG) ee : Moving file from /var/www/testsite222.com/htdocs/wp-config.php to /var/www/testsite222.com
2015-02-17 04:48:47,436 (DEBUG) ee : [Errno 2] No such file or directory: '/var/www/testsite222.com/htdocs/wp-config.php'
2015-02-17 04:48:47,437 (ERROR) ee : Unable to move file from /var/www/testsite222.com/htdocs/wp-config.php to /var/www/testsite222.com
2015-02-17 04:48:54,584 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2015-02-17 04:48:54,783 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7f27d6afc0f0>
2015-02-17 04:48:54,785 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteController object at 0x7f27d6afc400>
2015-02-17 04:48:54,786 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteDeleteController object at 0x7f27d6afc7b8>
2015-02-17 04:48:59,101 (DEBUG) ee : Removing Nginx configuration
2015-02-17 04:48:59,111 (ERROR) ee : testsite222.com does not exist in database

#12

@itdoug

Thanks for info,

In both the cases, ee couldnot find .my.cnf so that it can access mysql server. we are working on @rnovino server. so that we can fix the issue.


#13

@rnovino

I guess you did not install packages through EasyEngine, So its not created .my.cnf file.

So its causing issues with creating wp-config.php.

In this case create .my.cnf file in your home with contents

[client]

user=root

password=xxxxxxxx

#14

what directory am I going to put the .my.conf file? im on a linode server


#15

@harshadyeola

I installed mine through EE. There is a my.cnf.

cat ~/.my.cnf 
[client]
host=rds.FQDN.com
user=aws
password=PASSWORD

Strangely it kept insisting to install Percona even though I don’t want to use it. But once Percona installed I was able to update the my.cnf file.

I know it found the database server because there was a new DB in RDS, but no tables were created. I’m thinking this is where it’s stuck.

2015-02-17 04:48:47,436 (DEBUG) ee : ERROR 1045 (28000): Access denied for user  testsite222_com'@'localhost' (using password: YES)

Not sure why it is connecting to localhost.


#16

@rnovino

its path should be like /root/my.cnf


#17

@itdoug

Could you please, check if you can login to mysql shell.

use this

mysql


#18

now its showing this @harshadyeola

Setting up NGINX configuration  [Done]
Setting up webroot              [Done]
Downloading Wordpress           [Done]
Setting up database             Cannot create database

#19

@rnovino

It seems that your password is wrong in .my.cnf file.


#20

@itdoug

did you update /etc/ee/ee.conf

[mysql]

### MySQL database grant host name
grant-host = rds.FQDN.com