Unable to log in on default WP site


#1

Hi there,

first of all, to all the makers, thank you for all the hard work in making EE such a fantastic tool. I’m new to this, so please bear with me if I’m off track :expressionless:

I have installed EE (on top of an already working LEMP stack, replacing nginx with nginx-custom) and created a default website with sudo ee site create example.com --wpfc

Now I have a nice-looking default site, but I can’t log in to it - and I don’t understand why.

Here’s what I tried:

  • double-check admin username in SQL
  • update admin password with ee site update example.com --password
  • re-directed to my original WP site (which was still in /usr/share/nginx/example.com). Here I can log in just fine.
  • nginx -t shows no issues

The strange thing is that the site is not giving any feedback after inputting credentials (i.e. it doesn’t tell me that the credentials are incorrect). My original site does give such feedback.

One possible issue is that, when installing nginx-custom, I chose to keep the old /etc/nginx/nginx.conf file – and now I’m not really sure what the right configuration for EE is (by the way… can anyone point me in the right direction to configure nginx / my server to send emails?)

Thanks for any help you might be able to offer! Warner


#2

Hey there,

I’m kinda new at this as well, I’m sure someone more helpful will shine in, but meanwhile I’ll share my experience.

I’ve tried to do what you are trying to do and also wasn’t able to get it working. The reason I tried, was because I wanted it to work with pagespeed, but EE support for it stopped. Long story short after messing with it for countless hours and doing testing, just like everyone else I came to a conclusion that at least at this time pagespeed is not the ultimate answer.

It would be good to know the reason why you are trying to install EE on top of already existing LEMP stack? It’s very simple and straightforward to do a clean install. If you have an existing site that you want to move over to EE, there are simple ways to do it.


#3

Hi Kalach,

I’m not against getting a clean install, but I haven’t found any good instructions to do it… What I found was a list of “one-by-one” apt-get remove instructions (where many of the config files would still remain). I didn’t do that because I was uncertain about which config files I should manually remove.

Do you have a simpler way to do a clean install (without a complete system reinstall, that is ;))?

Warner


#4

Ok, for those who want to help, some more details:

Now I have two sites running. Both have the login issue, but now there’s more

  • one one (www.warner.photo) gives a ‘too-many-redirects’ issue, unless you go straight to warner.photo/wp-login.php (but after putting credentials you’re back to the redirects)

  • on the other (www.virtualityweb.com / http://93.55.208.188) you’re immediately redirected to the local address (unless you go straight to http://93.55.208.188/wp-login.php) and after putting credentials you’re shown the same screen on local address

Any help would be great!

Thanks a bunch :sunny:

Warner


#5

From a quick glance it looks like you didn’t properly setup cname records.

To do a clean install I usually run three commands that are on easyengine.io

So fire up a new Ubuntu 16.04 instance, ssh into it and run these commands.

  1. apt-get update

  2. wget -qO ee rt.cx/ee && sudo bash ee

  3. Whatever install that you want. I personally use redis. ee site create example.com --wpredis

Here’s a link


#6

EasyEngine is well documented with instructions and tutorials. This is just a community support forum. Most of the stuff is on easyengine.io


#7

The issue is that I’m not running a VM so I can’t start a new instance and run an install that easily.

Now I’ll try to remove all traces of EE and start over. I’ll let you know if that works out :wink:

Have a great day!


#8

One issue:

I have removed all config files (including those generated by EE in /etc/nginx/common and /etc/nginx/conf.d) and EE is not generating them again after running

  • ee stack purge
  • rm -r /etc/nginx
  • wget -qO ee rt.cx/ee && sudo bash ee

…any idea how to get these .conf files back?


#9

No sorry I don’t know how to get them back. I know that as of now EE is not supported on shared hosting, but it looks like you have access to command line, so I’m assuming you are not on a shared hosting.

When I tried to install EE on top of already installed Nginx it didn’t work properly at all. I think it needs it’s own fresh installation, but like I said, I’m also pretty new at this and don’t know a lot of things.

Talk to your hosting provider and see how you can get a fresh server or how you can erase everything to a clean state.

I’d also suggest “even for practice” purposes sign up for google cloud engine or Amazon Web Services. With both you get a VPS instance free for a year. That’s how I started. There are few other cheap alternatives that are easier to setup like: vultr, digital ocean(most popular one), linode.


#10

Oh and just a quick suggestion, from experience :joy: You’ll be making a lot of mistakes, so make sure to create snapshots(backups) before you try some new command.

Like in your case, if you deleted something and don’t know how to get it back, you could get your instance back to a previous state with a few clicks.


#11

@warner

If you are okay to try out a VPS restoration to get a clean VPS, you can contact your VPS provider support. (https://www.namecheap.com) would be providing those options since it is a very common need.


#12

@Kalach and @antopjoseph

for the moment I’m running this on my home server (and I’m starting to learn that a VPS might be a good thing for the future ;)).

Thanks a bunch for the hints - for sure I’ll look at the snapshots option before choosing a VPS.


#13