Unable to install WP -- Getting error while installing PHP


I am unable to install wordpress on my server using easyengine.

Everytime I run this command:

ee site create mysitename.in --wpfc
Adding repository for MySQL, please wait...
Adding repository for NGINX, please wait...
Adding repository for PHP, please wait...
**--- Logging error ---**
Traceback (most recent call last):
  File "/usr/lib/python3.5/logging/__init__.py", line 982, in emit
UnicodeEncodeError: 'latin-1' codec can't encode character '\ufffd' in position 366: ordinal not in range(256)
Call stack:
  File "/usr/local/bin/ee", line 9, in <module>
    load_entry_point('ee==3.7.4', 'console_scripts', 'ee')()
  File "/usr/local/lib/python3.5/dist-packages/ee-3.7.4-py3.5.egg/ee/cli/main.py", line 100, in main
  File "/usr/local/lib/python3.5/dist-packages/cement-2.4.0-py3.5.egg/cement/core/foundation.py", line 694, in run
  File "/usr/local/lib/python3.5/dist-packages/cement-2.4.0-py3.5.egg/cement/core/controller.py", line 455, in _dispatch
    return func()
  File "/usr/local/lib/python3.5/dist-packages/cement-2.4.0-py3.5.egg/cement/core/controller.py", line 455, in _dispatch
    return func()
  File "/usr/local/lib/python3.5/dist-packages/cement-2.4.0-py3.5.egg/cement/core/controller.py", line 461, in _dispatch
    return func()
  File "/usr/local/lib/python3.5/dist-packages/ee-3.7.4-py3.5.egg/ee/cli/plugins/site.py", line 598, in default
    ee_auth = site_package_check(self, stype)
  File "/usr/local/lib/python3.5/dist-packages/ee-3.7.4-py3.5.egg/ee/cli/plugins/site_functions.py", line 959, in site_package_check
  File "/usr/local/lib/python3.5/dist-packages/ee-3.7.4-py3.5.egg/ee/cli/plugins/stack.py", line 2443, in install
  File "/usr/local/lib/python3.5/dist-packages/ee-3.7.4-py3.5.egg/ee/cli/plugins/stack.py", line 191, in pre_pref
    EERepo.add(self, ppa=EEVariables.ee_php_repo)
  File "/usr/local/lib/python3.5/dist-packages/ee-3.7.4-py3.5.egg/ee/core/apt_repo.py", line 51, in add
  File "/usr/local/lib/python3.5/dist-packages/ee-3.7.4-py3.5.egg/ee/core/shellexec.py", line 33, in cmd_exec
    .format(cmd_stdout, cmd_stderr))
  File "/usr/local/lib/python3.5/dist-packages/ee-3.7.4-py3.5.egg/ee/core/logging.py", line 47, in debug
    self.app.log.debug(Log.HEADER + msg + Log.ENDC)
  File "/usr/local/lib/python3.5/dist-packages/cement-2.4.0-py3.5.egg/cement/ext/ext_logging.py", line 307, in debug
    self.backend.debug(msg, **kwargs)
Message: '\x1b[95mCommand Output: OK\n, \nCommand Error: gpg: keyring `/tmp/tmppvijjfft/secring.gpg\' created\ngpg: keyring `/tmp/tmppvijjfft/pubring.gpg\' created\ngpg: requesting key E5267A6C from hkp server keyserver.ubuntu.com\ngpg: /tmp/tmppvijjfft/trustdb.gpg: trustdb created\ngpg: key E5267A6C: public key "Launchpad PPA for Ond\\xc5\\x99ej Sur\ufffd" imported\ngpg: Total number processed: 1\ngpg:               imported: 1  (RSA: 1)\n\x1b[0m'
Arguments: ()

Updating apt-cache, please wait...
Installing packages, please wait...
^COops Something went wrong!!
Check logs for reason `tail /var/log/ee/ee.log` & Try Again!!!

Now when I try to check the log, this is what I get:

 php5.6-opcache php5.6-readline php5.6-recode php5.6-soap php5.6-xml
 php5.6-zip poppler-data postfix socat ssl-cert ttf-dejavu-core
0 upgraded, 136 newly installed, 0 to remove and 177 not upgraded.
Need to get 8,138 kB/65.6 MB of archives.
After this operation, 366 MB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/ondrej/php/ubuntu xenial/main amd64 php5.6-common amd64 5.6.32-1+ubuntu16.04.1+deb.sury.org+2 [2,750 kB]
Get:2 http://ppa.launchpad.net/ondrej/php/ubuntu xenial/main amd64 php5.6-json amd64 5.6.32-1+ubuntu16.04.1+deb.sury.org+2 [17.1 kB]
Get:3 http://ppa.launchpad.net/ondrej/php/ubuntu xenial/main amd64 php5.6-opcache amd64 5.6.32-1+ubuntu16.04.1+deb.sury.org+2 [62.2 kB]
2018-01-08 14:29:04,507 (INFO) ee : Oops Something went wrong!!
2018-01-08 14:29:04,507 (ERROR) ee : Check logs for reason `tail /var/log/ee/ee.log` & Try Again!!!

Any help is appreciated. Thank you.

Well this is the relevant error:- UnicodeEncodeError: ‘latin-1’ codec can’t encode character ‘\ufffd’ in position 366: ordinal not in range(256)

So you’ve got at least 1 character in your domain name that is not being recognised.

Not sure how to resolve the problem. Maybe locale settings will help?