Unable to Install MariaDB


#1

On a new fresh Debian 7 installation I installed EE and ran the following command:

ee stack install --MySQL

Then received this error:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: mariadb-galera-server-10.0 : Depends: mariadb-client-10.0 (>= 10.0.17+maria-1~wheezy) but it is not installable Depends: libmariadbclient18 (>= 10.0.17+maria-1~wheezy) but it is not installable PreDepends: mariadb-common but it is not installable Recommends: libhtml-template-perl but it is not going to be installed E: Unable to correct problems, you have held broken packages.

I’m not sure what this means, or how to fix it.

Also, when I install php and the utilities I get the following message, but everything is installed.

Unable to change owner : /var/www/22222


#2

As n update to this problem.

This is under EE 3.1.4 on Debian 7.

The command

ee stack install --MySQL

Runs just fine with no errors on Ubuntu 14.04 LTS.


#3

Hi @rdlynch

Please refer to this issue and comment

for the issue with debian 7.


#4

Hi @rdlynch

I hope your query is resolved. I am closing this support topic for now.

Feel free to create a new support topic if you have any queries further. :slight_smile:


#5