Unable to add new site anymore using EasyEngine


#1

Hi,

I just updated easy engine to its latest version and I’m unable to add a new site in my linode anymore. Could you show me how to correct this issue?

Thanks.

root@mail:/etc/ee# ee site create dummy.com --w3tc
Running pre-update checks, please wait...
Setting up NGINX configuration  [Done]
Setting up webroot              [Done]
Downloading Wordpress           [Done]
Setting up database             [Done]
Enter the WordPress table prefix [wp_]:
Unable to move file from /var/www/dummy.com/htdocs/wp-config.php to /var/www/dummy.com

root@mail:/etc/ee# ee -v
EasyEngine v3.2.2
Copyright (c) 2015 rtCamp Solutions Pvt. Ltd.

root@mail:/etc/ee# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.04 LTS
Release:        14.04
Codename:       trusty

Here’s the ee.log info.

2015-07-03 23:03:20,949 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2015-07-03 23:03:21,263 (DEBUG) ee : ['/usr/local/sbin/ee', 'site', 'create', 'dummy.com', '--w3tc']
2015-07-03
 23:03:21,264 (DEBUG) ee : collecting arguments/commands for 
<ee.cli.controllers.base.EEBaseController object at 
0x7f3b562bc080>
2015-07-03 23:03:21,268 (DEBUG) ee : collecting 
arguments/commands for <ee.cli.plugins.site.EESiteController object 
at 0x7f3b562afef0>
2015-07-03 23:03:21,270 (DEBUG) ee : collecting
 arguments/commands for <ee.cli.plugins.site.EESiteCreateController 
object at 0x7f3b562bcb38>
2015-07-03 23:03:21,274 (INFO) ee : Initializing EasyEngine Database
2015-07-03 23:03:21,283 (DEBUG) ee : Setting apt_packages variable for Nginx
2015-07-03 23:03:22,907 (DEBUG) ee : Finding string SCRIPT_FILENAME to file /etc/nginx/fastcgi_params
2015-07-03 23:03:22,908 (DEBUG) ee : Setting apt_packages variable for PHP
2015-07-03 23:03:24,692 (DEBUG) ee : Setting apt_packages variable for MySQL
2015-07-03 23:03:24,692 (DEBUG) ee : Running command: mysqladmin ping
2015-07-03 23:03:24,727 (DEBUG) ee : Setting apt_packages variable for Postfix
2015-07-03 23:03:26,558 (DEBUG) ee : Setting packages variable for WP-CLI
2015-07-03 23:03:26,559 (DEBUG) ee : Running command: which wp
2015-07-03 23:03:26,603 (INFO) ee : Running pre-update checks, please wait...
2015-07-03 23:03:26,604 (DEBUG) ee : checking NGINX configuration ...
2015-07-03 23:03:26,726 (INFO) ee : Setting up NGINX configuration
2015-07-03 23:03:26,727 (DEBUG) ee : loading template file /usr/lib/ee/templates/virtualconf.mustache
2015-07-03 23:03:26,881 (DEBUG) ee : Checking generated nginx conf, please wait...
2015-07-03 23:03:26,989 (INFO) ee : [Done]
2015-07-03 23:03:26,990 (DEBUG) ee : Creating Symbolic link, Source:/etc/nginx/sites-available/dummy.com, Dest:/etc/nginx/sites-enabled/dummy.com
2015-07-03 23:03:26,990 (INFO) ee : Setting up webroot
2015-07-03 23:03:26,991 (DEBUG) ee : Creating Symbolic link, Source:/var/log/nginx/dummy.com.access.log, Dest:/var/www/dummy.com/logs/access.log
2015-07-03 23:03:26,991 (DEBUG) ee : Creating Symbolic link, Source:/var/log/nginx/dummy.com.error.log, Dest:/var/www/dummy.com/logs/error.log
2015-07-03 23:03:26,991 (INFO) ee : [Done]
2015-07-03 23:03:27,099 (INFO) ee : Downloading Wordpress
2015-07-03 23:03:27,100 (DEBUG) ee : Changing directory to /var/www/dummy.com/htdocs/
2015-07-03 23:03:27,100 (DEBUG) ee : Running command: wp --allow-root core download
2015-07-03 23:03:27,840 (INFO) ee : [Done]
2015-07-03 23:03:27,841 (INFO) ee : Setting up database
2015-07-03 23:03:27,841 (DEBUG) ee : Creating database dummy_com
2015-07-03 23:03:27,844 (DEBUG) ee :
2015-07-03 23:03:27,846 (DEBUG) ee : Exceuting MySQL Statement : create database `dummy_com`
2015-07-03 23:03:27,847 (DEBUG) ee : Creating user dummy_com
2015-07-03 23:03:27,847 (DEBUG) ee : create user `dummy_com`@`localhost` identified by ''
2015-07-03 23:03:27,849 (DEBUG) ee : Setting up user privileges
2015-07-03
 23:03:27,851 (DEBUG) ee : Exceuting MySQL Statement : grant all 
privileges on `dummy_com`.* to `dummy_com`@`localhost`
2015-07-03 23:03:27,852 (INFO) ee : [Done]
2015-07-03 23:03:29,049 (DEBUG) ee : Changing directory to /var/www/dummy.com/htdocs/
2015-07-03 23:03:29,049 (DEBUG) ee : Setting up wp-config file
2015-07-03 23:03:29,050 (DEBUG) ee : Generating wp-config for WordPress Single site
2015-07-03
 23:03:29,050 (DEBUG) ee : bash -c "php /usr/bin/wp --allow-root core 
config --dbname='dummy_com' --dbprefix='wp_' --dbuser='dummy_com' 
--dbhost='localhost' --dbpass= --extra-php<<PHP


define('WP_DEBUG', false);
PHP"
2015-07-03 23:03:29,113 (DEBUG) ee : Command Output: Could not open input file: /usr/bin/wp
,
Command Error:
2015-07-03 23:03:29,114 (DEBUG) ee : Moving file from /var/www/dummy.com/htdocs/wp-config.php to /var/www/dummy.com
2015-07-03 23:03:29,115 (DEBUG) ee : [Errno 2] No such file or directory: '/var/www/dummy.com/htdocs/wp-config.php'
2015-07-03 23:03:29,115 (ERROR) ee : Unable to move file from /var/www/dummy.com/htdocs/wp-config.php to /var/www/dummy.com
2015-07-03 23:03:38,643 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2015-07-03 23:03:39,009 (DEBUG) ee : ['/usr/local/sbin/ee', '-v']
2015-07-03
 23:03:39,009 (DEBUG) ee : collecting arguments/commands for 
<ee.cli.controllers.base.EEBaseController object at 
0x7f71dc784fd0>

Can't install Wordpress
#2

Hi, Anyone knows how to fix this?


#3

@jkfriends

looks like wp file causing issue.

can you give me output for fillowing command?

which wp


#4

Here you go:

root@mail:~# which wp
/usr/local/bin/wp

More info: Looks like I can’t find wp-cli anywhere in my system.

root@mail:~# ls /usr/bin/wp
/usr/bin/wp

root@mail:~# file /usr/bin/wp
/usr/bin/wp: broken symbolic link to `/usr/share/easyengine/wp-cli/bin/wp'

root@mail:~# ls /usr/share/easyengine
ls: cannot access /usr/share/easyengine: No such file or directory

root@mail:~# find / -name wp-cli
root@mail:~#

#5

I’m also having the same kind of problem. It seems the ee script tries to access a directory that’s not available (i.e. “DirectoryIterator::_construct(/tmp/wp558190b90d87a/)”) because “wordpress” was uncompressed to a directory named “wordpress” and not “wp_558190b90d87a”… Is this an script problem or anything else? It seems to be that the wordpress install script is expecting an uncompressed folder different than the actual one…

Regards


#6

Hi, Anything we can try? Please let us know on how to fix this issue.


#7

@jkfriends

location where EasyEngine finds the wp is /usr/bin/wp.

So to fix this problem you can do following thing

rm /usr/local/bin/wp

rm /usr/bin/wp

ee stack install --wpcli


#8

It worked. Thank you so much :slight_smile:


#9

Would this have anything to do with the:

ee site create dummy.com --w3tc

…command being run from /etc/ee as quoted from the O.P.?


#10

Hi @bamajr, I did try from other directories too before posting the question here - exactly same error.

After fixing wp-cli package (per @harshadyeola suggestion) , creation of site works just fine now.


#11

The best part of this is that it is now working for you. However, I’m curious if anyone can explain why this happened and what to do to prevent it from happening in the future?


#12

Tried, rebooted, no do… still the same kind of error… :frowning:


#13

ee stack remove --wpcli ; ee stack install --wpcli

You’re welcome.


#14

Same, problem, i trie this but not work

Command Output: Downloading WordPress 4.8.2 (en_US)… md5 hash verified: 2e8744a702a3d9527782d9135a4c9544 , Command Error: Error: Couldn’t extract WordPress archive. unable to decompress gzipped phar archive “/tmp/wp_59c90f0e6389e.tar.gz” to temporary file


#15