Ubunut 17.04 or 17.10


#1

Hello,

Today I was setting up a droplet on Digital Ocean and was on auto pilot. Once the droplet was set up I SSH’d in and ran the command to install easyengine and got an error I never got before…

“EasyEngine (ee) only support Ubunutu 12.04/14.04 and Debian 7.x/8.x”

I immediately said, “I have installed EE on dozens of droplets running Ubuntu 16.04… what are you talking about?” (Yes, I talk to my machine.) So I get back into DO and notice that while on auto pilot I had selected Ubuntu 17.04. So this brings me to two questions:

  • Why did I get this warning about 12.04 and 14.04 when I know for a fact I have EE running on many Ubuntu 16.04 setups?
  • When is the expected support for Ubuntu 17.04 going to roll out?

Thank you for all that will participate in this thread.

MQ


#2

As far as I know, 17.xx won’t never be supported, only LTS releases.

So, your best shot now is Ubuntu 16.04.


#3

portofacil,

That makes sense. What about the error about only working on 12.04 and 14.04? Is this something that just needs to be updated in the error codes so that it also lists 16.04? It might help someone just trying out EE and accidentally setting up 17.x and thinking they need to go back to 14.04.

Thank you


#4

This error message should be changed (to inform compatibility with 16.04), but I’m just an user like you, I cant fix this because I’m not a developer. :frowning:


#5

I have edit this message and add Ubuntu 16.04 LTS in the list. It should be applied as soon as my pull request is accepted


#6

@virtubox,

Nice! I think it will help avoid confusion for new users.

Thank you


#7