Ubuntu 16.04 LTS fresh install gives error


#1

Hello everyone, i just tried to install easy engine V4 running the wget command on a fresh installation of Ubuntu

I got an error:
/usr/bin/env: ‘php’: No such file or directory

I installed php 7.2 manually and i got then :
“Error: could not find driver”

Any ideas?


#2

I had the same issue on a fresh server… and I installed PHP 7.2 cli which fixed it. I followed this guide and started at step 3: https://www.rosehosting.com/blog/how-to-install-php-7-2-on-ubuntu-16-04/

At some point I did have to uninstall/kill Apache 2 because it was blocking some ports, once EE4 was installed successfully.


#3

Thanks for the reply!
I did exactly the same thing with the same tutorial last night and it worked for me as well.
Like everything else, easy engine is not perfect but i really appreciate. Them guys did some serious work!


#4

i’m having the same issue with ee comands I get " Error: could not find driver"
tried the guide with no help


#5

Can your VPS run Docker?


#7

@Georgios_ch @bowefrankema @hyperburst Did you try to install with the following command -

wget -qO ee rt.cx/ee4 && sudo bash ee

If you installed EE with above command then can you please attach the output of /opt/easyengine/logs/install.log here?


#8

@kirtan

yes i used the above command. Here the output of my log file

install.log


#9

Fix your apt-get update and try to re-install EE v4 again, it should work.