Trouble accessing the admin tools when using Cloudflare


#1

Hi guys,

The site is behind Cloudflare so domain.com:22222 is not loading but I’m using direct.domain.com:22222 to bypass Cloudflare and access the admin tools and it works.

The problem is that I’ve given the login details to the client but he cannot access the page. Apparently it works only from my computer.

I have used ee secure --ip to whitelist his IP but still no luck. Also, IP is whitelisted in CSF.

Is there anything I’m missing? Can you help?


#2

@AndreiChira

As you mentioned direct.domain.com:22222 is worked for you but not for your friend

Possible reason:

  1. DNS is not updated on your friend system

  2. What happens when your friend try to access direct.domain.com:22222, Its good if your friend provide us screen shot/

Possible Solution:

Use ip address instead of domain name. Ask your friend to open https://1.1.1.1:22222

Replace 1.1.1.1 with your server public ip address


#3

@miteshshah

When he tries to access the page the browser (Chrome) returns the “Webpage not available” error. When clicking details it shows “Error code: ERR_CONNECTION_TIMED_OUT”. Using the IP instead of the domain name doesn’t solve it, it’s the same error.

I have asked more friends to try (different cities, even country) and they have the same error. It only works from my computer or if I disable Cloudflare, then it works for all.


#4

@AndreiChira

Its good if you give us your actual server name and ip address so we can test it.


#6

I have done a lot of tests with CloudFlare and WordPress… CloudFlare is fine as CDN only, as it helps with Yahoo Yslow and Google Pagespeed ratings at GTmetrix. However, all of the other features of CF will cause problems if you are using plugins for caching, minifying and so on…

Try this…

Click on the DNS for the domain name in CloudFlare, Edit DNS it says, Click any of the clouds that are Orange, they will be greyed out if they are turned off.

Go back to the domain list, and choose CloudFlare Settings, you’ll be at the Settings Overview page, Disable everything except put the CDN to CDN only!

Security Settings Tab, Just turn everything off!

On the performance settings tab, for Caching level, set it to aggressive, and set Minimum expire TTL to 8 Days…

Turn off all 3 minify options, they will be greyed out and turn off Rocket Loader…

This is how I run cloudflare since I use PHP5-APCU full page caching with the WP-FFPC plugin, and Autoptimize for minify.

You can use the settings I provided as a start, then turn things on 1 by 1 in cloudflare if you need other options. Just be sure to purge the cloudflare cache after making changes and CTRL+F5 to clear your browser.

Hope this helps, Chris


#7

Have you tried disabling CSF?

You’re missing the point of a CDN.


#8

CDN’s are hype and cause reduced latency issuees and they are not needed if you know what you are doing… Just so many misconceptions of WordPress… It’s been this way for so many years…


#9

I see. Good luck then on using CDN to achieve perfect speed test score rating.


#10

I already get good ratings with no cdn… Look at the source code, http://mywpdev.com

I only use CloudFlare to manage my domains only… I was just giving tips to his problem.


#11

@faizi

Yes, it was a CSF problem, I have solved it. Thank you.


#12

Hello @AndreiChira

I hope your query is resolved. I am closing this support topic for now.

Feel free to create a new support topic if you have any queries further. :slight_smile:


#13