There was some error in starting services_global-nginx-proxy_1 container

When creating a site the error occurs: Error: There was some error in starting services_global-nginx-proxy_1 container. Please check logs.

follows the error log:

[03-03-2019 23:49:37] ee.INFO: ::::::::::::::::::::::::ee invoked::::::::::::::::::::::::

COMMAND: docker ps > /dev/null
RETURN CODE: 0


COMMAND: command -v docker-compose > /dev/null
RETURN CODE: 0

Using default global config: /opt/easyengine/config/config.yml
No project config found
argv: /usr/local/bin/ee site create mysite.com.br --type=php --ssl=le
Running command: site
COMMAND: which docker
RETURN CODE: 0

COMMAND: docker inspect -f ‘{{.State.Running}}’ services_global-nginx-proxy_1
STDOUT: false
RETURN CODE: 0


COMMAND: docker network inspect ee-global-backend-network
STDOUT: [ { “Name”: “ee-global-backend-network”, “Id”: “0c3186f4ae3f4e5f9d47416a73719cb4361136253ec0aa18bb445b65d48b44fc”, “Created”: “2018-11-29T21:30:02.357309234Z”, “Scope”: “local”, “Driver”: “bridge”, “EnableIPv6”: false, “IPAM”: { “Driver”: “default”, “Options”: {}, “Config”: [ { “Subnet”: “172.18.0.0/16”, “Gateway”: “172.18.0.1” } ] }, “Internal”: false, “Attachable”: false, “Ingress”: false, “ConfigFrom”: { “Network”: “” }, “ConfigOnly”: false, “Containers”: {}, “Options”: {}, “Labels”: { “org.label-schema.vendor”: “EasyEngine” } } ]
RETURN CODE: 0


COMMAND: docker network inspect ee-global-frontend-network
STDOUT: [ { “Name”: “ee-global-frontend-network”, “Id”: “a7143232caf8f7d45d32591e1c859fd70544cf2fcdf17c2b13269147f12dd403”, “Created”: “2018-11-29T21:30:02.66337447Z”, “Scope”: “local”, “Driver”: “bridge”, “EnableIPv6”: false, “IPAM”: { “Driver”: “default”, “Options”: {}, “Config”: [ { “Subnet”: “172.19.0.0/16”, “Gateway”: “172.19.0.1” } ] }, “Internal”: false, “Attachable”: false, “Ingress”: false, “ConfigFrom”: { “Network”: “” }, “ConfigOnly”: false, “Containers”: {}, “Options”: {}, “Labels”: { “org.label-schema.vendor”: “EasyEngine” } } ]
RETURN CODE: 0


COMMAND: docker-compose up -d global-nginx-proxy
STDERR: Starting services_global-nginx-proxy_1 … e[1Ae[2K Starting services_global-nginx-proxy_1 … e[31merrore[0m e[1B ERROR: for services_global-nginx-proxy_1 Cannot start service global-nginx-proxy: OCI runtime create failed: container_linux.go:348: starting container process caused “process_linux.go:297: copying bootstrap data to pipe caused “write init-p: broken pipe””: unknown ERROR: for global-nginx-proxy Cannot start service global-nginx-proxy: OCI runtime create failed: container_linux.go:348: starting container process caused “process_linux.go:297: copying bootstrap data to pipe caused “write init-p: broken pipe””: unknown Encountered errors while bringing up the project.
RETURN CODE: 1

ee.ERROR: There was some error in starting services_global-nginx-proxy_1 container. Please check logs.

Does anyone know how to solve

Now, Mr. Rajdeep_Sharma just come to close this topic!
This community has become a bin with only questions and no help.
I keep tracking questions to find someone closing the topic!

1 Like

This issue is not caused by EasyEngine. It seems like an issue with Docker. Please check this GitHub issue. https://github.com/docker/for-linux/issues/591

You might need to upgrade the Linux Kernel and/or the Docker package.

1 Like

Thank you very much!

I have same problem and i fixed by reinstall docker compose with command
sudo curl -L “https://github.com/docker/compose/releases/download/1.24.0/docker-compose-$(uname -s)-$(uname -m)” -o /usr/local/bin/docker-compose

More in link: https://docs.docker.com/compose/install/
It’s worked.

1 Like

Thanks! This saved me a lot of time. During regular install, the docker install regularly fails (at least, for the last couple of days, caused by slow transfer speeds). EE continues installing without warning and you obviously can’t install sites as a result.

Small correction on the command:
sudo curl -L "https://github.com/docker/compose/releases/download/1.24.0/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose

(different quotes…)