Testing Website in IP and Port


#1

I’m having a very “complex” (coff, usual) workflow , because the developers are working in an other country and we are UX designers and because of the Client Budget, Yolo , we are managing the testing and production server.

Developers are asking me to have a test environment like http://ip:8989

But when I change the listen and server_name, next restart nginx, and then I tried to access via Browser. I’m always redirect to the default_server root.

my service_available file is consist of:

22222

# EasyEngine admin NGINX CONFIGURATION

    server {

      listen 22222 default_server ssl spdy;

      access_log   /var/log/nginx/22222.access.log rt_cache;
      error_log    /var/log/nginx/22222.error.log;

      ssl_certificate /var/www/22222/cert/22222.crt;
      ssl_certificate_key /var/www/22222/cert/22222.key;

      # Force HTTP to HTTPS
      error_page 497 =200 https://$host:22222$request_uri;

      root /var/www/22222/htdocs;
      index index.php index.htm index.html;

      # Turn on directory listing
      autoindex on;

      # HTTP Authentication on port 22222
      include common/acl.conf;

      location / {
        try_files $uri $uri/ /index.php?$args;
      }

      # Display menu at location /fpm/status/
      location =  /fpm/status/ {}

      location ~ /fpm/status/(.*) {
        try_files $uri =404;
        include fastcgi_params;
        fastcgi_param  SCRIPT_NAME  /status;
        fastcgi_pass $1;
      }

      location ~ \.php$ {
        try_files $uri =404;
        include fastcgi_params;
        fastcgi_pass php;
      }

      # ViMbAdmin Rules
      location = /vimbadmin/ {
        return 301 $scheme://$host:22222/vimbadmin/public/;
      }

      location ~* \.(js|css|jpg|gif|png)$ {
        root /var/www/22222/htdocs/;
      }

      location ~* /vimbadmin/public/(.*)/(.*) {
        root /var/www/22222/htdocs/vimbadmin/public;
        try_files $uri $uri/  /vimbadmin/public/index.php?$args;
      }

      location ~* /vimbadmin/public/(.*) {
        root /var/www/22222/htdocs/vimbadmin/public;
        try_files $uri $uri/  /vimbadmin/public/index.php?$args;
      }

    }

mytestwebsite

server {
    listen 8888;

    server_name http://myipserver:8888;

    access_log /var/log/nginx/mywebsite.access.log rt_cache;
    error_log /var/log/nginx/mywebsite.error.log;

    root /var/www/mywebsite/htdocs;

    index index.php index.html index.htm;

    include common/php.conf;
    include common/wpcommon.conf;
    include common/locations.conf;
    include /var/www/mywebsite/conf/nginx/*.conf;
}

default

##
# You should look at the following URL's in order to grasp a solid understanding
# of Nginx configuration files in order to fully unleash the power of Nginx.
# http://wiki.nginx.org/Pitfalls
# http://wiki.nginx.org/QuickStart
# http://wiki.nginx.org/Configuration
#
# Generally, you will want to move this file somewhere, and start with a clean
# file but keep this around for reference. Or just disable in sites-enabled.
#
# Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.
##

# Default server configuration
#
server {
	listen 80;
	listen [::]:80;

	# SSL configuration
	#
	# listen 443 ssl default_server;
	# listen [::]:443 ssl default_server;
	#
	# Self signed certs generated by the ssl-cert package
	# Don't use them in a production server!
	# include snippets/snakeoil.conf;
	#
	# ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # don’t use SSLv3 ref: POODLE
	# ssl_ciphers HIGH:!aNULL:!MD5;
	# ssl_prefer_server_ciphers on;

	root /var/www/html;

	# Add index.php to the list if you are using PHP
	index index.html index.htm index.nginx-debian.html;

	server_name _;

	location / {
		# First attempt to serve request as file, then
		# as directory, then fall back to displaying a 404.
		try_files $uri $uri/ =404;
	}

	# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
	#
	#location ~ \.php$ {
	#	include snippets/fastcgi-php.conf;
	#
	#	# With php5-cgi alone:
	#	fastcgi_pass 127.0.0.1:9000;
	#	# With php5-fpm:
	#	fastcgi_pass unix:/var/run/php5-fpm.sock;
	#}

	# deny access to .htaccess files, if Apache's document root
	# concurs with nginx's one
	#
	#location ~ /\.ht {
	#	deny all;
	#}
}


# Virtual Host configuration for example.com
#
# You can move that to a different file under sites-available/ and symlink that
# to sites-enabled/ to enable it.
#
#server {
#	listen 80;
#	listen [::]:80;
#
#	server_name example.com;
#
#	root /var/www/example.com;
#	index index.html;
#
#	location / {
#		try_files $uri $uri/ =404;
#	}
#}

Is there any way I can achieve this ?

Thank you!


#2

Some customers request IP:port access for development tasks, and I thin it is stupid in so many levels.

First, EE is not a good server for development. One always will find the cache on JSs and CSSs the worst annoyance ever.

Second, why the hell can’t developers use a simple subdomain, like dev.example.com, using plain HTTP on port 80? Why do they have to ask for stupid environments when there are simpler solutions already tested for and by thousands of people?

(Sorry for the rant, I feel much better now.) :wink:


#3