Stuck on "Executing apt-get update, please wait..."


#1

I have tried updating EE with sudo ee update and wget -qO eeup rt.cx/eeup && sudo bash eeup. I get the message "Executing apt-get update, please wait..."

My last log entry says "upating EasyEngine, please wait...".

When I try to close the terminal, it asks me to make sure because a process is still running. The update never gets past the previously stated messages.

Anyone have any ideas on what is happening/what I should do?


#2

Hello @unclemusclez

Could you manually run the command

sudo apt-get update

and check if apt-get update is successful manually


#3

@unclemusclez

could you please provide ee logs.

tail -n50 /var/log/ee/ee.log


#5

sudo apt-get update works


#6

I am not at the machine currently, but as I stated in the original post, there is no indication of error in/var/log/ee/ee.log. My logs end with "upating EasyEngine, please wait..." each time I try to run the update. It never gets past that point and the log does not indicate any further progress.


#7

@unclemusclez hey

i seem to be getting the same error did you ever fix the issue?


#8

I think I hit “enter” in the command windows and then it kept going. I searched the logs and errors showed up. I am currently able to run it fine, but this same error occurred recently. If you just hit “enter” or “return” it should skip past the message. You may need to give it a minute or so. This should be marked as a bug as it still exists in Ubuntu Desktop 14.04.


#9

That worked! thank you :))


#10

I guess I found the problem. I stuck also at that part. then i ran sudo apt-get update. and that one stuck as well. looked at Internet. It seems it is related to Ipv6 . where connecting over IPv6 on some servers causes them to get stuck at this point. The fix is

Open /etc/gai.conf

Uncomment the following line:

precedence ::ffff:0:0/96 100

https://zach-adams.com/2015/01/apt-get-cant-connect-to-security-ubuntu-fix/


#11