Strange problems with wordpress


#1

I’ve been using the latest version of easyengine with the redis cache on a 1gb Linode for a while now and it worked great. It’s basically a default setup except for configuring https. Recently I had issues where my menus in wordpress disappeared and I could no longer save changes to them, also category pages would give a 404 error. The site itself worked fine except for menus and categories.

I assume it was some kind of database corruption or other issue, I restored a linode backup from as far back as 10 days ago even before the wordpress 4.3 update and the same issues started happening. I did all the normal troubleshooting like clearing caches, browser cache, even different computers. I thought it might be a resource issue, but my server always had plenty of available free memory. Finally I cloned my server over to a 2GB Linode on a different ip and now everything works perfectly. This seemed to resolve the issue. I was just wondering if anyone had a idea what would cause this, it was such a strange issue I couldn’t find anything online that was helpful.


#2