Stalled after migrating to MariaDB


#1

I ran the command to migrate to MariaDB and it appears stuck at Installing MariaDB, please wait … It was stuck for a good 30 minutes before I had to give up and restore a backup of the digital ocean droplet. Here’s a zip of the log (site db names have been changed) http://d.pr/f/Q8BG

Any ideas?


#2

Hi,

From logs it look like you need to first update all system packages, you can use following command to upgrade system:

apt-get update
apt-get upgrade
apt-get dist-upgrade

After that you can migrate to MariaDB. I hope this will help you.


#3

Thanks I ran those commands, then ran ee stack restart and I had a 502 gateway error on all my sties, I rebooted the VM and still nothing, so I attempted to run the migration and while the migration completed my sites where still gone. While running the command you posted I chose to keep all defaults (default php.ini etc)


#4

Good news, re-ran the update a 2nd time and it went through flawlessly Thanks!


#5

Hi @coreyallen

Glad to know your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#6