Stable forum site now having cache issues


#1

Hello, first off thank you rtCamp for EasyEngine.

The caching / login issue is only happening in a WordPress BBPress/BuddyPress site forum with Ubuntu 16.04 LTS. It was stable since the past few weeks if not months (hard to pinpoint when it started), then users started to report login and posting issues.

I don’t have any problems with my other non-forum sites on multiple VPS’s.

The problem:

Users try to login to the website by using sidebar login or login page and it gets redirected back to the same page without the page refreshing as the user is logged in. I can see the logs with a plugin in the backend that shows the user was able to logged in successfully but like I said the user would not see any difference after clicking the login button. Therefore the users keep trying to login and nothing happens.

Findings:

Since I can’t log in through the browser to see what’s going on, I noticed the homepage was not displaying any changes in activity for very long periods of time so I think is a caching issue.

I tried to use sudo ee clean --all and restart Nginx but nothing changed. It was able to go back to normal by doing a sudo reboot but after a few hours it started all over again.

df -h displays tmpfs /run only using 2% and all other filesystems are basically empty, so the hard drive is not full.

Changed fastcgi.conf to WORDPRESS:100m from 50 thinking it was some space issue but nothing.

I did noticed the other day when I updated Nginx Helper plugin that the Redis Object Cache displayed it was not connected, so I had to sudo reboot for that because restarting all services was not working, but I did not happen to see it like that anymore after.

I tried to check the logs recently for Nginx Helper and it supposedly was purging stuff but I am not sure how much is supposed to show in the log because I only saw new topics getting purged and not the homepage.

In the end Purge Cache was not clearing anything unless I sudo reboot so I could login.

Temporary Fix:

  • I disabled the Redis Object Cache on the back end of WordPress.
  • Uncheck the purge on Nginx Helper and save.
  • Cronjob with sudo ee clean --all every 5 minutes (I am not sure why it’s working now, maybe a plugin issue?).

I do not like the approach of clearing it every few minutes but is temporary until can figure out and also not sure if it will break again.


Database has:

  • 172 Forums
  • 3,342 Topics
  • 23,307 Replies
  • 5,476 Users

I was thinking to revert back to some old versions of Nginx Helper and Redis Object Cache plugins to see if that’s the problem.

I appreciate any input or ideas in what might be causing this.

It used to be stable for many months :frowning:

Thanks in advance.


#2