SSL site down after Ubuntu "required" reboot


#1

Ok I’ve really messed something up and I can’t seem to find a solution after many searches. Basically, my SSL site was working fine before I logged into SSH and saw a message saying “system reboot required”. I took a snapshot of my EC2 before doing it and proceeded with the sudo reboot command.

After about 3 minutes I was able to SSH into the server and I proceeded to make sure my sites were online. That’s when I noticed my SSL site (iowish.com) would not respond and connection was timing out. My non-SSL site with the same plugins installed works fine though.

I tried to think of what I did specific to the SSL site besides just adding the SPDY directives because going back to a basic nginx config for that site did not work. If this has anything to do with it, I did set up a crontab to run the wp-cron tasks specifically for that server and I notice that they are gone or somehow not showing up when I go to crontab -e now.

I’m basically a novice with Linux so I rely heavily on the rtCamp forums and a few others to get me where I’m at until my vision for the site pays off and I can hire someone because this is driving nuts.

Any help, suggestions or direction would be much appreciated. I can’t even remember the tail command to look at the error log for nginx that I used to use and doing a search for it on rtCamp or google is proving futile - it’s just one of those commands I ran across during an EE tutorial and it’s lost in all of the other clutter.

… and ps, I also tried an UpdraftPlus backup from a fresh wordpress install (non-ssl) and everything worked until the database was restored and it directed me to return to the Updraft management page. So, could the DB have gotten messed up after a reboot?

Thanks in advance!!


#3

Above is not related to SSL issue. It can be safely ignored.

Can you try SSL setup again? Or can you try removing SSL temporarily.

I think the issue is related to SSL only. May be SSL keys are missing.

What nginx error log says without debug mode? I am sure if a site is down, there must be an [error] level message.


#7

Thank you for your help @rahul286. I did get this figured out and here is what I had to do to get it going again:

  1. disable wpfc cache globally
  2. reinstall SSL
  3. remove fail2ban
  4. flush, then purge iptables
  5. rebuild iptables
  6. enable wpfc cache globally
  7. test and pull OCSP certificate validation
  • for some reason SSL is not starting up properly on boot and the firewall locked 443 down completely. I’ll try to do more research when I find time but for now, I’m making backups of the working server and WP and trying to get my real content in place.

NOTE - I need to find an alternate solution to fail2ban unless it’s even necessary when I have Wordfence plugin installed.


#8

Hi @mattylb

Glad to know that you fixed it yourself.

It’s been a long time, and we haven’t heard from you. I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#9