Split: rtMedia issues


#1

I checked to see what this new update is compatible with, and it is NOT compatible with Buddypress 1.7.2, which of course I updated the other day. it's only compatible up to 1.7. So they just haven't been quick enough. I have disabled the plugin, and am just waiting for the right update to come along. Then we'll see what the deal is.


#2

What about those of us that are still stuck with the frozen migration page, even when we try and update with 3.0.1? 3.0.1 is of no use to us. I sent you a screenshot of that page. When I went in to my media area of my profile, I saw, of course, that it was not complete, because migration was not complete. The thing is, when I turned off all the plugins, all my rtMedia problems persisted. Major problems with this plugin at its most basic levels. The problem is it is not even close to being compatible with WP 3.5.2, or with BP 1.7.3. That's the basic issue here. The next one is, that the changes are big enough from the previous version of Buddypress Media (now rtMedia), that you should have placed a warning to everyone as you had done with the 1.7 release. Otherwise, you were signaling that this update was no big deal. And it is.


#3

So where and how should we be creating a "new thread"??


#4

@interglobalmedia@gmail.com

Hi,

As you can see, we are working on all the issues that have been reported by all the users. You might have noticed that the issue you are facing is not universal. However, how-much-so-ever irritating it may seem, we can only proceed with each if we have the issues streamlined.

I'm spending more time figuring out who's posting where and why apart from the emails. Please don't post in every thread possible. This is not at all constructive and not helping either of us.

Neither of us are under any obligation to be patient with each other. However, not cooperating will get us nowhere.

Regards.


#5

@interglobalmedia@gmail.com Please post only on this thread we've created specially for you.

Regards.


#6

How can you say that this is not universal, when there was a post regarding migration made concerning this issue by one of your developers? And, a whole bunch of users were complaining about said issue all night. I am very patient, and I have been using Buddypress (and Wordpress) for a very long time. Wordpress has always been great.. It would be nice if you guys would actually explain how and where to create the tables necessary for this migration, as these tables didn't end up being created, and if said documentation would be available to everyone so that we wouldn't have to keep on bugging you about it. Thanks in advance for all your help. You shouldn't have released this version to the public. It was way too soon. You're still in beta as far as I can see.


#7

Hi,

Now, our team has been looking into the migration issues faced by several users. Some of them, including you, kindly gave us access to their sites to see what went wrong. Some of them, we could fix immediately, while others have certain unique problems that we are working on.

As and when we find some issues that can be taken care of by a change in the code, we'll release an update. That exact update may not work on your specific site. Please be patient.

When we develop the code, we try and incorporate as many scenarios as possible. The 'as possible' is the key phrase here. We cannot account for every possible detail. That is why, we are always ready to get into individual sites that are affected the most.

Your site seems to have taken a serious beating with this update, unlike any other. We are looking into it and will update as soon as we have a useful insight/fix.

Do let us know, at the same time, if subsequent releases help in any way.

Regards.


#8

I understand, believe me. None of this is new to me, and I'm trying to help you with my input as well, because I do have much experience in this space. Don't worry, if anything changes, I will immediately let you know. I am just as anxious that you guys succeed, as you are. I know that this venture has been a long time in the making, and it's also unique. I just suggest, going forward, that you place a warning like you had with 1.7 release, so that people will create backups. Otherwise, believe, me, they won't bother. Thanks for all your help and your open source work, in advance.

Best regards,

Maria


#9

Hi Maria,

We found that a piece of code that locates our database schema files wasn't working on some PHP versions. We've fixed that. Please confirm if this solves the issues you've been facing.

If not, could we have admin access to your site, so we could explore the issue in detail. You can send it to saurabh.shukla@rtcamp.com.

Regards.


#10

Saurabh, I just explained how I think I was successful with migration utilizing the 3.0.1 update on the LetsBSocial.com website. And as I had mentioned, I thought there might have been something incorrect hidden in the migration.php file. Thanks so much for your help!

Best regards,

Maria


#11

This was located in migrmn's thread about not being able to upload media: "Can not upload media". What I wrote below:

I removed the code that I implemented at your suggestion, and “reverted back” to what was there. Then I went in, and updated to 3.0.1 (again – i had this before, and it didn’t work). The I went in to migrate. The stuck migration was still there, but, when I tried again, it was successful! Then I went into my media area, to check on an upload I had done previously, but during my attempts at updating and migrating (I did it before migration had been completed, and it didn’t initially upload). Saurabh, the new look for photos is really great. The previous one had been pretty ugly. So far, so good! I’m going to try and upload a new photo now, to make sure that everything is working well. Thank you!

I also had disabled another plugin that I had updated at the same time as rtMedia, before I had updated to rtMedia 3.0.1 this time around, and perhaps that contributed to the success. The plugin, in case if anyone else is using it, is Shareaholic share and related content button. They had made some major changes to their application as well. Perhaps this had contributed! There also might have been hidden spaces created in the rtMedia migration php file, that I might have gotten rid of, when I went in to edit it. Perhaps it just needed a reboot!

Hope this helps.

Best regards,

Maria


#12

Saurabh:

I just tried uploading a new photo, and it worked without a hitch. Just wanted to let you know.

Maria


#13

There, is, however, a problem with the photo editor. It only shows everything in landscape, and not in portrait, so portrait photos are cut off. And I can't do anything to change that in the editor. Just an FYI.


#14

Also, I get the following prompt:

There are unsaved changes that will be lost. 'OK' to continue, 'Cancel' to return to the Image Editor.

However, there is no "OK" button or "Continue" button. Just cancel and save. And, when I enter an aspect ratio, I can't put anything into the selection area below it. Hope this helps.

Maria


#15

Hi,

Those are css issues. That's something that we've been locked with from the start. Which is why, this time, we built a templating system. You'd have to make some changes to the templates' markup and/or css to make this work with your particular theme.

Regards.


#16

Ok. So then where is the CSS file to make such changes? There is none in the rtMedia folder.


#17

It never was like that before! This is something entirely new that has popped up. And before, I was able to make changes. Now, this simply is not working. Nothing changes. So it is not a css issue, its a functionality issue. Photo editing is not functioning! And I tried it with a Buddypress default theme too.


#18