[SOLVED] Site deleted, can't create it again


#1

Hi everyone !

After a lot of tests and debug, I can’t get to understand my problem. I have a website I’m working on installed with EE and WooCommerce. Everything is working fine, but when I try to end my order on the checkout page, the spinning loader on the summary of the order stay here spinning.

I’m using SSL, but I don’t think that this is the problem (I’m running other woocommerce installs with EE and SSL that are working fine).

So I decided to delete the website, after doing some backups, and create it again. Except that now I can’t create the website :

ee site create site.com Running pre-update checks, please wait… Setting up NGINX configuration [Done] Setting up webroot [Done] Reload : nginx [Failed] Oops Something went wrong !! Calling cleanup actions … Reload : nginx [Failed] service nginx reload failed. check issues with nginx -t command. Check logs for reason tail /var/log/ee/ee.log & Try Again!!! root@me:/var/www# nginx -t nginx: the configuration file /etc/nginx/nginx.conf syntax is ok nginx: configuration file /etc/nginx/nginx.conf test is successful root@me:/var/www# tail /var/log/ee/ee.log 2016-07-19 11:48:38,419 (DEBUG) ee : Removing /etc/nginx/sites-available/site.com 2016-07-19 11:48:38,419 (INFO) ee : Reload : nginx 2016-07-19 11:48:38,449 (DEBUG) ee : nginx: the configuration file /etc/nginx/nginx.conf syntax is ok nginx: configuration file /etc/nginx/nginx.conf test is successful reload: Unknown instance: 2016-07-19 11:48:38,449 (INFO) ee : [Failed] 2016-07-19 11:48:38,486 (DEBUG) ee : Removing /var/www/site.com 2016-07-19 11:48:38,486 (DEBUG) ee : Removing /var/www/site.com 2016-07-19 11:48:38,499 (INFO) ee : service nginx reload failed. check issues with nginx -t command. 2016-07-19 11:48:38,500 (ERROR) ee : Check logs for reason tail /var/log/ee/ee.log & Try Again!!! root@me:/var/www# ee stack restart Restart : nginx [OK] Restart : php5.6-fpm[OK] Restart : php7.0-fpm[OK] Restart : mysql [OK] Restart : postfix [OK]

I have the last version of EE.

Any clue ?

Thanks !!!


#2

What happens when you run nginx -t?


#3

Nothing special : nginx: the configuration file /etc/nginx/nginx.conf syntax is ok nginx: configuration file /etc/nginx/nginx.conf test is successful

That’s why I’m really confused :confused:


#4

Try rebooting your server. Let us know if it helps.


#5

Ok so that’s something I didn’t tried and it worked. Do you have an idea why it was happening ?

Thanks a lot !


#6

I think Nginx was updated at some point, but the executable in RAM didn’t match the one actually installed, causing conflicts.

Once you rebooted you cleaned all instances of everything from RAM, allowing the server to load everything as it should be.


Ee site update example.com --php7 / Backing up database [Fail]
#7

Ok ! Thanks a lot. Next time, I WILL try the reboot first :slight_smile:


#8

Sometimes a reboot ca do real magic. :wink:


#9