[SOLVED] Purge Redis cache doesn't work


#1

I have Wordress with --wpredis with everything in lasted version.

And have two plugin

  • Nginx Helper
  • Redis

When I edit anything in my site, the cache doesn’t flush. (old result in non-login page)

But if I use

  • Flush Cache in Redis plugin
  • sudo ee clean --all

It will work.

what should I do ? my config is correct right?

SOLVED


#2

Have you checked the settings for the Redis plugin (i.e. turned it on)?


#3

Thanks .

Sorry for my newbie, just edit the prefix to example.com:

or others that show in redis key or in Redis plugin.


#4

What exactly solved your problem? My redis cache is not purged after post change and everything is running and enabled? If I flush Redis Object Cache manually it works as expected.


#5

define your redis key in your “wp-config.php” file like

define( 'WP_CACHE_KEY_SALT', 'yoursite.com:' );

and go to wp-admin check your necessary plugin: nginx-helper, wp-redis.


#6

I found the issue was caused by the WP_CACHE_KEY_SALT line being automatically added to wp-config in the wrong place - this seems to be the fault of EasyEngine.

The line should be placed somewhere above the line: require_once ABSPATH . ‘wp-settings.php’;

Once moved, things started working.


#7