[SOLVED] Mail Stack VIMBAdmin Unexpected error


#1

OK so I have a website installed and working fine. Next I installed the whole stack using the “ee install stack all” command

Everything worked perfectly, but when i go to VIMB admin i get this error:

Doctrine\DBAL\Exception\ConnectionException File /var/www/22222/htdocs/vimbadmin/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php Line 103 Message An exception occurred while executing 'SELECT COUNT(a0_.id) AS sclr_0 FROM admin.admin a0_': SELECT command denied to user 'vimbadmin'@'localhost' for table 'admin' Code 0 Trace
#0 /var/www/22222/htdocs/vimbadmin/vendor/doctrine/dbal/lib/Doctrine/DBAL/DBALException.php(116): Doctrine\DBAL\Driver\AbstractMySQLDriver->convertException('An exception oc...', Object(Doctrine\DBAL\Driver\Mysqli\MysqliException))
#1 /var/www/22222/htdocs/vimbadmin/vendor/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(836): Doctrine\DBAL\DBALException::driverExceptionDuringQuery(Object(Doctrine\DBAL\Driver\Mysqli\Driver), Object(Doctrine\DBAL\Driver\Mysqli\MysqliException), 'SELECT COUNT(a0...', Array)
#2 /var/www/22222/htdocs/vimbadmin/vendor/doctrine/orm/lib/Doctrine/ORM/Query/Exec/SingleSelectExecutor.php(50): Doctrine\DBAL\Connection->executeQuery('SELECT COUNT(a0...', Array, Array, NULL)
#3 /var/www/22222/htdocs/vimbadmin/vendor/doctrine/orm/lib/Doctrine/ORM/Query.php(306): Doctrine\ORM\Query\Exec\SingleSelectExecutor->execute(Object(Doctrine\DBAL\Connection), Array, Array)
#4 /var/www/22222/htdocs/vimbadmin/vendor/doctrine/orm/lib/Doctrine/ORM/AbstractQuery.php(969): Doctrine\ORM\Query->_doExecute()
#5 /var/www/22222/htdocs/vimbadmin/vendor/doctrine/orm/lib/Doctrine/ORM/AbstractQuery.php(924): Doctrine\ORM\AbstractQuery->executeIgnoreQueryCache(NULL, 4)
#6 /var/www/22222/htdocs/vimbadmin/vendor/doctrine/orm/lib/Doctrine/ORM/AbstractQuery.php(804): Doctrine\ORM\AbstractQuery->execute(NULL, 4)
#7 /var/www/22222/htdocs/vimbadmin/vendor/doctrine/orm/lib/Doctrine/ORM/AbstractQuery.php(833): Doctrine\ORM\AbstractQuery->getSingleResult(4)
#8 /var/www/22222/htdocs/vimbadmin/application/Repositories/Admin.php(27): Doctrine\ORM\AbstractQuery->getSingleScalarResult()
#9 /var/www/22222/htdocs/vimbadmin/application/controllers/AuthController.php(52): Repositories\Admin->getCount()
#10 /var/www/22222/htdocs/vimbadmin/vendor/opensolutions/oss-framework/src/OSS/Controller/Trait/Auth.php(99): AuthController->_preLogin()
#11 /var/www/22222/htdocs/vimbadmin/vendor/zendframework/zendframework1/library/Zend/Controller/Action.php(516): AuthController->loginAction()
#12 /var/www/22222/htdocs/vimbadmin/vendor/zendframework/zendframework1/library/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('loginAction')
#13 /var/www/22222/htdocs/vimbadmin/vendor/zendframework/zendframework1/library/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#14 /var/www/22222/htdocs/vimbadmin/vendor/zendframework/zendframework1/library/Zend/Application/Bootstrap/Bootstrap.php(105): Zend_Controller_Front->dispatch()
#15 /var/www/22222/htdocs/vimbadmin/vendor/zendframework/zendframework1/library/Zend/Application.php(382): Zend_Application_Bootstrap_Bootstrap->run()
#16 /var/www/22222/htdocs/vimbadmin/public/index.php(34): Zend_Application->run()
#17 {main}

Things I have tried:

1)Using the default stack command (This Error) - The Database Connection is fine from SSH Terminal as well as from PHPMyAdmin

2)Followed Custom Guide (https://rtcamp.com/tutorials/mail/server/postfix-dovecot-ubuntu/) - Everything worked fine but after i created the mailbox in VIMBAdmin, Access to it through roundcube didnt work :frowning:

Kindly Help. Only Mail Server is remaining else I am almost done with my server. Also I am using Linode with Debian 7 if it may be needed at all.

Thank you. Have a nice day.


#2

@stecomminfo,

Hi, Try following:

vim /usr/local/lib/easyengine/lib/ee_lib_variables.sh +16

Change 3.0.10 to 3.0.11

Let me know it works for you


#3

Not working. Still the same error. I read somewhere in this forum, that this error will be fixed in EasyEngine 3.0 If thats the case then i can wait 1-2weeks if that is the timeframe of EE3.0 release. Either ways my main linode running 2 websites is using EasyEngine web packages without mailserver.

I am doing all this R&D on another Linode till I get my mail server up and running here wont do anything on the main linode,

Thanks for the help, See if u can help any further. Thank you.


#4

I had the same issue. Moving to 3.0.11 solves the issue.

But I had to start over completely from scratch. On a blank Debian 7 first install EasyEngine, then change the value from 3.0.10 to 3.0.11 in the /usr/local/lib/easyengine/lib/ee_lib_variables.sh file. Then “ee stack install all”. After that ViMbAdmin works fine :slight_smile: What would be the way to fix it without starting from scratch again?

Note that during the installation process I get the following failures:

[FAIL] Clamav signatures not found in /var/lib/clamav … failed!

[FAIL] Please retrieve them using freshclam … failed!

[FAIL] Then run ‘/etc/init.d/clamav-daemon start’ … failed!

Not sure it that is really an issue? Any comments on that?

BTW, when is version 3 of EasyEngine coming out?

Thanks in advance! After testing a bunch of control panels, I ended up with no control panel at all, just plain EasyEngine instead :slight_smile:


#5

I have the same issue @gau1991 recommendation didn’t work any workaround with this I don’t want to start from scratch need asap


#6

Starting from Scratch does solve the problem Completely. Thanks a lot @gau1991 and @ddelaey. You guys rock.

My Server Setup is finally complete :slight_smile:

@ddelaey About those Clam errors. I just run the commands it states in the Error and the output seems to be fine for the same. See below.

root@(none):~# freshclam ClamAV update process started at Wed Feb 11 06:00:44 2015 WARNING: Your ClamAV installation is OUTDATED! WARNING: Local version: 0.98.5 Recommended version: 0.98.6 DON’T PANIC! Read http://www.clamav.net/support/faq main.cvd is up to date (version: 55, sigs: 2424225, f-level: 60, builder: neo) daily.cvd is up to date (version: 20054, sigs: 1322939, f-level: 63, builder: neo) bytecode.cvd is up to date (version: 245, sigs: 43, f-level: 63, builder: dgoddard)

root@(none):~# /etc/init.d/clamav-daemon start […] Starting ClamAV daemon: clamd /usr/sbin/clamd already running. . ok root@(none):~#


#7

Hi @stecomminfo

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#8