Solution: nginx: [warn] the "ssl" directive is deprecated, use the "listen ... ssl" directive instead


#1

EE v3.8.1

Ubuntu 18.04 LTS on AWS,

Default LEMP Stack with Additional Modules such as Ngixn EE and ee-acme-sh.

If you are using the mainline NGINX your will receive an error such as:

nginx: [warn] the “ssl” directive is deprecated, use the “listen … ssl” directive instead

I am using Nginx v1.15.x

Cause of the error: http://hg.nginx.org/nginx/rev/46c0c7ef4913

If you’re on SSL and listening on 443, commenting out ssl on; as shown below.

#ssl on;

Will be the solution!

Regards!


#2

simply typing #ssl on; on the ssh command will do?


#3

Hello,

no you have to comment the directive ssl on; in your nginx vhost configurations, in /var/www/yourdomain.tld/conf/nginx/ssl.conf


#4

I have my ssl installed on vesta. I searched for ssl.conf file using sudo find / -name “ssl.conf” and it gave me 3 such files. /usr/local/vesta/install/rhel/5/httpd/ssl.conf /usr/local/vesta/install/rhel/6/httpd/ssl.conf /usr/local/vesta/install/rhel/7/httpd/ssl.conf What should I do now? Please do reply.


#5

Did that :slight_smile:


#6

Try

/usr/local/vesta/install/rhel/7/httpd/ssl.conf


#7

server { listen 127.0.0.1:443 ssl; #update like this #ssl on; #delete or comment this line ssl_certificate ssl/api.coms.crt; ssl_certificate_key ssl/api.coms.key; . . }