So, I cannot update to EE 3.8


#1

Hi all,

This is getting old … I cannot upgrade from 3.7.5 to 3.8

Errors : Downloading update script Unable to download file, /tmp/eeupdate20180605- 155659

Then I tried : sudo -i wget -qO ee https://raw.githubusercontent.com/EasyEngine/easyen gine/master/install && bash ee

and it gives me :
Update EasyEngine to 3.8.1 (y/n): y [ Tue Jun 5 15:57:54 UTC 2018 ] Not updating EasyEngine to 3.8.1, exit status = 1

Anyone out there who knows what’s the solution ? I am in a situation here…I either upgrade or I change away from EE immediately, since I have some projects to launch…

Thanks, Lex


#2

To move away from EE you need to launch a fresh server in order to install whatever you want.

In such case, launch the new server and install EE 3.8 on it, then migrate your domains.

Or go away; just tell us what you chose to replace EE, the information might be of interest of a lot of people here.


#3

You mean that installing EE on a fresh server will install 3.8 ? Can’t I just delete EE from my server now and reinstall EE ?


#4

Yes, it will.

No, you can’t.


#5

I have setup a fresh 18.04 server and will be having a EE 3.8 install on one and a Webinoly install on another … I will see which one is better for me and go with that …

Lex


#6

You can just run the installation command and it will update your installation.

wget -qO ee rt.cx/ee && sudo bash ee


#7

I tried that … it didn’t work …

I have switched to webinoly for now …


#8

I’d love to hear about your impressions on Webinoly. If you find more appropriate, please PM me, if you feel the desire to share. :slight_smile: Thanks.


#9

You can force ee update by removing removing /usr/local/bin/ee.

rm -rf /usr/local/bin/ee
wget -qO ee rt.cx/ee && sudo bash ee

Otherwise, take a look on the directory /tmp

@portofacil, about Webinoly, I haven’t found the time to test it yet, but I have take a look on the code, and it’s nice to see bash functions instead of python


#10

I second that! :slight_smile:


#11

How do you find webinoly.