SMTP Server Setup


#1

Any tips how to make wordpress and cf7 deliver emails? Tried some plugins also!

PHPMailer ErrorInfo: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting Mailer: smtp Host: smtp.zoho.com Port: 465 SMTPSecure: ssl SMTPAutoTLS: bool(false) SMTPAuth: bool(true)

I have no idea what to do!


#2

Hello,

personally, I prefer to use formidable form rather than cf7. It do the same, without having to edit templates. Then use Easy SMTP on port 465 with SSL enabled.


#3

Thanks man! Never heard about formidable i ll check it. Easy smtp is good and also WP Mail SMTP.

Although i ve checked another site on the same server with gmail settings and it works.


#4

I can’t recommend postmarkapp.com enough. They strictly provide transactional email support so your mail never ends up in spam. You can easily offload marketing emails to other services that are a dime a dozen.


#5

My experience with Zoho is that they have restrictions (protections) in place that make it challenging to consistently use them as an SMTP gateway. I have had no issues with the free tier of SendGrid and/or Amazon SES (paid, but very inexpensive). Both options have worked great with high levels of deliverability.


#6

To be honest, if i have to pay i ll go with google!


#7

Yeah, Zoho can be a real frustration but it’s free! So…


#8

I use Yandex Mail for one or two domains, it is less frustrating than Zoho. But it is a real pain to configure it. I don’t know if it’s because of language barriers or what, but it was very hard to put everything to work.


#9

I agree about Yandex, configuration isn’t easy. But Zoho was really painful for me too, without DKIM support for all emails sent with phpmailer scripts.

So I have switched to Google Gsuite, and it provide 1TB storage for $8/mo, and unlimited storage if you are at least 2 users.

But to receive your own emails from your contact form, it doesn’t matter if you use a free mail hosting service like yandex, even without your own domain. My comments notifications on my own blog are send with a @yandex.com email.