Sites Gone after 3.6.0 upgrade


#1

Hello,

so today I upgraded a server to 3.6.0 and after that nginx is showing the “default” page instead of the correct sites.

I see that in sites-enabled there is nothing.
I see that in sites-available there is nothing.

If I output the ee sites list ee knows that sites exist. If I try and recreate the site it says it is already present and will not create. The files are still present on the server, just nginx that is messed up after the update “ee update” was all I ran.

I have tried reloading the stack, rebooting the server and still same isue.

:/etc/nginx/sites-enabled$ ee site list domain1.com domain2.com domain3.com

/etc/nginx/sites-enabled$ ee site edit domain.com nginx configuration file does not exists :/etc/nginx/sites-enabled$ ls 22222 default :/etc/nginx/sites-enabled$ ee site enable socialsuits.isademo.com nginx configuration file does not exist

any help on this… I am newer to using ee.


#2

i was about to upgrade but after seeing this im going to wait

hey guys we need some help over here

at least some confirmation that you’ve seen the post :slight_smile:


#3

@digitalpure Could you share following details with us:

  1. The command you used to upgrade EasyEngine
  2. OS version you are using(in case you upgraded do share that too)
  3. Content of /var/log/ee/instal.log

#4

@ssalil I just ran “ee update” on my 14.04 64bit Ubuntu install. I cannot send you the install log any longer as I had to get the sites back online as it was a production server so I reinstalled the OS and EE.

David


#5

Hi @digitalpure

Apologies for the issues faced by you.

To bring it to your knowledge, We use git for our nginx version controlling. So in future if you come across any such issue you can use git log and revert to a previous commit. That will revert the nginx folder and configuration to it’s older state and you can get your sites-available/sites-enable folder back.

Unfortunately, we tried to reproduce the same scenario on our end but wasn’t able to. Can you please tell us which hosting provider you are using?


#6

thanks for the heads up with the git log… i knew it was going to git just did not think about doing a repo check and reverting.

this is on a private vps with 4GB of ram, using OpenVZ as the container.


#7