Site redirecting back to IP from domain


#1

I am using the easyengine setup with nginx and HHVM configure for example.com. The site was built originally using the IP address until I was able to switch it over. For some reason, after following a bunch of guides on how to switch to the new domain, the site redirects to the IP which just shows the static “nginx working” page. From what I can see the wordpress settings are correct, the sites-enables nginx conf file is correct. All I can think of is maybe it’s HHVM acting up or the default server nginx conf file. One thing i do notice is when i tail HHVM log file [hphp] [1711:xxxx.xxxxxxxxxxxx.xx.xxxxxx] [] \nWarning: failed to connect to 127.0.0.1 [111]: Connection refused

Any help much appreciated!


#2
cd /var/www/example.com/htdocs
wp option get site_url

What do you get when you run the commands above?


#3

Ended up resetting with snapshot. Going to try again if I run into it again I will let you know.

I did set the URL within wp-settings so its should have been example.com and not the IP


#4

Ok so I am testing again and tried your command for craps and laughs and this is what I am getting:

PHP Warning: Redis::connect(): connect() failed: Connection refused in /var/www/xxx.xxx.xxx.xxx/htdocs/wp-content/plugins/nginx-helper/includes/redis-delete.php on line 15 Warning: Redis::connect(): connect() failed: Connection refused in /var/www/xxx.xxx.xxx.xxx/htdocs/wp-content/plugins/nginx-helper/includes/redis-delete.php on line 15


#5

I also get the same error if I do a wp search-replace of my IP to my domain


#6

Nevermind, it turns out there was an issue with the DNS that was set up. Basically switching back and forth from one rule to the other. Thank you for the help!


#7