Site not displaying on various pc's/laptops but displaying on others


#1

Very strange.

I setup my linode to debian 8.1 with this 3 commands from easyengine.

wget -qO ee rt.cx/ee && sudo bash ee

ee stack install --all

ee site create relaxtime.gr --wp.

The site displays fine on my pc (windows 7) and my mobilephone and some of my friends mobiles and pc.

But two of my friens computers with windows 7, display:

welcome to nginx If you see this page, the nginx web server is successfully installed and working. Further configuration is required. For online documentation and support please refer to nginx.org Please use the reportbug tool to report bugs in the nginx package with Debian. However, check existing bug reports before reporting a new bug. Thank you for using nginx.

why?


#2

I checked on my Mac and it seems to be working fine, I suspect it’s probably a caching issue, try getting the other computers to access it on incognito mode, see if that works.


#3

My experience with this issue (especially on phones using Google Chrome) led me to signing up for Premiere support for a month. I thought it was the cache as well. I did multiple troubleshoots and hours and hours of rebuilding.

For me, ip6v had to be enabled in my easyengine site config. It was enabled on my Linode, but not in the default site config. Here’s what rt support wrote:

I have added following config in your site configuration for enabling ipv6.

    listen 80;
    listen [::]:80;

EasyEngine default supports site with ipv4. So added this config.

For yoursite.com you can do following steps

  • ee site edit yoursite.com
  • add above two lines in server block.

I feel like this issue pops up repeatedly on this forum. It would be really advantageous for the ee folk to provide a troubleshooting wiki for this particular circumstance.


#4

Hello and thank you very much to help me. (flower_sniffer)

Now the site is ok.

God Bless You !!!


#5