Site keeps redirecting to https after disabling lets encrypt


#1

Hi, I had lets encrypt enabled in one of my sites and then I wanted to turned it off. I did so as instructed, by executing the command ee site update example.com --letsencrypt=off. But my site keeps redictering to https. what other steps I need to implement in order to redirect all requests to http again. Below are my nginx conf. any suggestions would be highly appreciated . thanks!

server { server_name www.bibeat.com bibeat.com; return 301 http://bibeat.com$request_uri; }

server {

server_name bibeat.com;


access_log /var/log/nginx/bibeat.com.access.log rt_cache;
error_log /var/log/nginx/bibeat.com.error.log;


root /var/www/bibeat.com/htdocs;



index index.php index.html index.htm;


include common/wpfc-php7.conf;

include common/wpcommon-php7.conf;
include common/locations-php7.conf;
include /var/www/bibeat.com/conf/nginx/*.conf;

}


#2

Check this location /etc/nginx/conf.d and if there’s a file force-ssl-bibeat.com.conf

edit it and remove or comment out the following line in the server block like so:

server {
        listen 80;
        server_name www.bibeat.com bibeat.com;
        #return 301 https://bibeat.com$request_uri;
}

#3

If the answer from tyrro don’t solve your problem, try with another browser because modern browser like chrome will definitively follow a 301 redirect. Clear your cache and cookies.


#4

Hi tyrro, I found the file “force-ssl-bibeat.com.conf.disabled” instead of the file you mentioned. So I assume your solution is not applicable for this file ?


#5