Site Creation is failing: missing nginx/common/ files (resolved)


#1

I’ve tried creating a wp + supercache + hhvm site., wp + supercache, and finally just a wp site.

Each time it fails at the same point. This is on a fresh install of Ubuntu 16.04. In each case, there is a file missing in /etc/nginx/common/ (in fact the common directory itself is missing).

Command lines

  1. sudo ee site create maddog.example.com --wpsc --user=user --pass=‘password’ --email=email --hhvm
  2. sudo ee site create maddog.example.com --wpsc --user=user --pass=‘password’ --email=email
  3. sudo ee site create maddog.example.com --wp --user=user --pass=‘password’ --email=email

Corresponding error #1: Reload : nginx 2018-05-13 21:02:42,617 (DEBUG) ee : nginx: [emerg] open() “/etc/nginx/common/wpsc-hhvm.conf” failed (2: No such file or directory) in /etc/nginx/sites-enabled/maddog.example.com:19 nginx: configuration file /etc/nginx/nginx.conf test failed

Corresponding error #2: 2018-05-13 20:58:00,710 (INFO) ee : Reload : nginx 2018-05-13 20:58:00,725 (DEBUG) ee : nginx: [emerg] open() “/etc/nginx/common/wpsc.conf” failed (2: No such file or directory) in /etc/nginx/sites-enabled/maddog.example.com:19 nginx: configuration file /etc/nginx/nginx.conf test failed

Corresponding error #3: 2018-05-13 21:04:38,222 (INFO) ee : Reload : nginx 2018-05-13 21:04:38,239 (DEBUG) ee : nginx: [emerg] open() “/etc/nginx/common/php.conf” failed (2: No such file or directory) in /etc/nginx/sites-enabled/maddog.example.com:19 nginx: configuration file /etc/nginx/nginx.conf test failed


#3

I am not sure what happened here. But did you try and install your own version of NGINX?

I am NO expert in NGINX. But had this issue a while back. I think I had to remove the current version of NGINX and reinstall the EE version.


#4

No. Quite literally the only commands issued on this vps wer adduser user and give it sudo apt update && apt upgrade ee install ee site create

sudo dpkg -l |grep nginx

ii nginx-common 1.10.3-10ppa~stable

ii nginx-custom 1.10.3-10ppa~stable

ii nginx-ee 1.10.3-10ppa~stable


#5

First install hhvm only then install wp supercache by using wordpress rather than ee or you can go with --wpfc Nginx fast cgi cache better then supercache


#6

Turns out the problem is that the VPS default install has apache enabled. This was causing the failure of nginx to run because port 80 was already bound to apache.

Once I got that resolved, then I had to fix another problem with php-fpm

listen = /var/run/php5-fpm.sock …should read: listen = 127.0.0.1:9000

Interestingly that particular problem seems to be still here from 2015. You’d think that somewhere in the last three years, that would have been fixed.


#7

Actually, you shoulnd’t have any PHP, MySQL or webserver installed before EasyEngine.

If you follow this simple requirement the installation is smooth and straightforward.