Settings unsaveble


#1

I just tried to update from rtMedia 3.5 to 3.5.2.1, but when i did, i could no longer save changes to any settings in rtMedia back en settings. The “Save settings” button didn’t do anything, simply put. I restored the 3.5 version, and everything works fine. Something is definitely wrong with 3.5.2.1 version…

I’m using WordPress 3.8.1 and BuddyPress 1.8.1


#2

We checked it on our demo site and is working perfectly fine. Can you give some more details, are there any server or JS error? Can you please check it on the fresh WordPress setup with default theme and other plugins disabled.


#3

This problem is at the back end, not the front end


#4

Can you please check it with other plugin disabled and with default theme? If that doesn't works, try it on fresh WordPress setup.


#5

I tried deactivating all plugins but rtMedia and BuddyPress, and also tried different themes like Twenty Twelve, Twenty Thirteen and Twenty Fourteen, but the save settings button still does nothing. I then made a new site and installed the latest WordPress, BuddyPress and rtMedia, and then it does work. However, this is an impossible solution for me, because i have spent half a year making my site, there is no chance that i can spend another half a year redoing everything from the ground up, it is simply not a reasonable solution. I need to know how to fix this on my current installation, or else i simply cant use rtMedia...


#6

That's strange. With new setup everything working fine, but not with existing setup. No one facing this issue :| Is your WordPress have cache? It will be hard for us to debug by giving random solution, so its better if you provide admin access of your site @ nitun.lanjewar@rtcamp.com. Will check and let you know. Thanks, --Nitun


#7

Yea, my site uses WP Super Cache, and Autoptimize. However, while Autoptimize is an active plugin, is not set to minimize anything right now.

I will not give anyone admin access to the official site, however i have set up a development site which is a direct copy of the official on with its own database. I have already checked, and the same error exists there. Register as a member on it, and i will change the rights to admin. But write down any solution you will find, because when you are done, i will restore the entire site to what it was before you started changing things, and redo the solution myself. This is to ensure that both sites are exact copies of each other.

I have added a admin user for you on this site, you should get the log in information in your email.

Also, i'm currently not using the latest rtMedia version, so you will have to update it when you start your bug checking.


#8

I have checked the settings and saved them number of times, each time Save settings button worked for me. I don't even deactivated any plugin/theme. Don't know why its not working for you. Which browser you are using? I have checked it on Firefox, Chrome and IE 10.


#9

As i tried to notify you in a private message on the site, you where looking in the wrong place. It is not the users settings that has this problem, it is the general settings in the back end. You have to go to the admin pages in order to see anything, that is why you needed admin rights isn't it?

Read the private message i sent you on the site, it has the web address for the admin pages in it. Also, i have to repeat that the problem isn't there now, because i reverted to an older version of rtMedia. If you want to see the problem, first log in, the go to the admin pages. Now go to the rtMedia general settings. Change something and hit "Save Settings". It should work fine. Now update the rtMedia plugin and try it again, it should fail. That is the problem.


#10

Please check your private messages again, you still didn't update rtMedia. Of course it works, the problem only happens when rtMedia is updated. I thought you would like to update so you could see for yourself that it is the latest update that causes the problem. Anyway, i have updated it now, so now the problem is there, you can no longer save settings.


#11

Its working fine now. Try to save settings of rtMedia now, it will work fine for you as well. Don't know what was the problem. I just deactivated other plugins and activated those again and its started working. :|


#12

Yes it works now, but how do i do it again on the official site? I need to know exactly which plugins you deactivated and activated....


#13

I have deactivated all the plugins except rtMedia and buddyPress. That is the only thing I did. If same process do not work on your official site, then, I can suggest you to delete rtMedia and install it again. Hope that may work. Another option, I just tested with my local WP setup, try to add value 1 in rtMedia -> Settings -> Image Sizes -> Number of thumbnails to generate on video upload.

Thanks, --Nitun


#14

I see. Well, unfortunately the update still haven't fixed the issue i did a bug report about a while back ( https://rtcamp.com/support/topic/editing-images-does-not-update-thumbnails/#post-55522 ) so there is simply no reason for me to bother with the update at this time...


#15