Setting up database: an integer is required


#1

Facing a strange issue since today, to all of my boxes.

After upgrading wp-cli in order to bypass the WordPress core extraction error, it seems that my create command is stack at the db user.

Seems like instead of getting a normal name for the db user, ‘none’ is sent, causing chaos.

Any suggestions?

2017-10-09 11:23:17,423 (DEBUG) ee : ^[[95mCreating database my_website_com^[[0m 2017-10-09 11:23:18,351 (DEBUG) ee : ^[[95m**[Error]Setting up database: ‘an integer is required** (got type str)’^[[0m 2017-10-09 11:23:18,351 (DEBUG) ee : ^[[95m^[[0m 2017-10-09 11:23:18,351 (DEBUG) ee : ^[[95mMysql Connection problem occured^[[0m 2017-10-09 11:23:18,351 (DEBUG) ee : ^[[95mdropping user **None**^[[0m


#2