Server issues after update


#1

I updated ee to latest version as mentioned in the release blog post, and installation went fine and no issues came up during the process.

Though after the update when I point my domain it doesn’t come. I tried to fetch site using gtmetrix and they gave me a error saying unable to fetch the site.

How do I sort this out?


#2

Hi Arjun

Please provide the output of following command
nginx -t

Al


#3

I did no config mods after that, but the site comes, but takes too much of time to load.

nginx -t gives me

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok  
nginx: configuration file /etc/nginx/nginx.conf test is successful  

#4

Hello Arjun,

Your nginx configuration is ok did you just restart the nginx, php5-fpm and mysql services and test the website. also can you give me your server current load average.

service mysql restart  
service php5-fpm restart  
service nginx restart

#5

Everything seems to be fine at the moment there.

Though now I’m facing issues on my homepage. It shows a cached version only. Whatever code I update to my homepage template, it doesnt show up. I’m on W3TC, with homepage caching disabled. Also I tried purging the homepage, but still no use. Any idea?


#6

Hi Arjun,

Did you install and configure nginx-helper plugin?
nginx-helper plugin purge the cache when some contents are modified.

You can manually purge by using the following commands
rm -rf /var/run/nginx-cache/*


#7

Now after restarting everything, nothing’s happening. I’m being thrown a 504.

The issue that stands now is the homepage purge, it doesn’t show what update I make to the homepage template file.


#8

Its good if you provide your website error.log file for debugging purpose.
Also send me the output of following command:

ee info


#9

There seems to be something wrong with the server. At times the site never loads and I’ve to reload nginx to get the site back running.

ee info

  
Nginx (nginx/1.4.1) Information:  

Nginx User:                      www-data  
Nginx worker_processes:          1  
Nginx worker_connections:        1024  
Nginx keepalive_timeout:         65  
Nginx fastcgi_read_timeout:      300  
Nginx client_max_body_size:      100m  
Nginx Allowed IP Address:        127.0.0.1  

PHP (5.5.6-2) Information:  

PHP User:                        www-data  
PHP expose_php:                  Off  
PHP post_max_size:               100M  
PHP upload_max_filesize:         100M  
PHP max_execution_time:          300  

PHP ping.path:                   /ping  
PHP pm.status_path:              /status  
PHP pm.max_requests:             500  
PHP pm.max_children:             100  
PHP pm.start_servers:            20  
PHP pm.min_spare_servers:        10  
PHP pm.max_spare_servers:        30  
PHP request_terminate_timeout:   300  
PHP Fastcgi Listen:              127.0.0.1:9000  

MySQL (5.5.34) Information:  

MySQL User:                      mysql  
MySQL port:                      3306  
MySQL wait_timeout:              28800  
MySQL Max_used_connections:      19/151  
MySQL datadir:                   /var/lib/mysql/  
MySQL socket:                    /var/run/mysqld/mysqld.sock  

EasyEngine (ee) Common Locations:  

phpMyAdmin:                      http://example.com/pma  
PHP Status:                      http://example.com/status  
Nginx Status:                    http://example.com/nginx_status  
Opcache & Memcache Status:       http://example.com/ee/  
EasyEngine Log File:             /var/log/easyengine/install.log  
EasyEngine Configuration File:   /etc/easyengine/ee.conf  

Error Log
My error.log file is blank and there was another file error.log.1 which I have attached here.


#10

Hello Arjun,

First decrease mysql wait_timeout to 300; vim /etc/mysql/my.cnf wait_timeout = 300

Restart mysql service mysql restart

Please copy/paste the contents of following file /var/log/nginx/example.com.access.log /var/log/nginx/example.com.error.log


#11

Made the mysql wait_timeout changes.

Attaching both the log files.

access.log http://pastebin.com/7iRrW8wF error.log http://pastebin.com/T5cCTcqW

Note: There's something wrong with attaching file to the forum.


#12

Hi Arjun,

On error .log i'm notice two issue

  1. upstream timed out (110: Connection timed out)
  2. MySQL server has gone away

Its a good if you provide me a shell access to debug your server and fix the issue asap.


#13

Hey Mitesh, LMK your e-mail so that I can provide you access.


#14

You can send me the details on Mitesh.Shah@rtcamp.com


#15

List of changes made on server

Change MySQL Following Settings

vim /etc/mysql/my.cnf max_connections = 50 wait_timeout = 300 interactive_timeout = 300

Permission Issue: the 777 permission is given to the web-root, which is not recommended, Fix the web-root permission

The main issue is caused by the w3-total-cache plugin so rename that plugin and restart the php5-fpm service, Now server load drops from 7.0+ to 0.3 :)

Let me know if you still face any issue.


#16

Thanks for the help Mitesh.

Everything was fine and as I mentioned, I got a 504 now and it got back to normal after I reloaded nginx service. Any thoughts?


#17

Hi Arjun,

Please disable w3-total-cache sometime and check your site performance. When I'm check your server, your server is overloaded and w3-total-cache cause the problems So please make that plugin disable sometime and motinor your site you get any 504 error.


#18