rtPanel Child: empty style.css on scss change


#1

Hi there, Having some issues with Grunt watch in the rtPanel Child. When changing something in the /assets/rtpanel/scss/ I get the notification:

File “assets/rtpanel/scss/_responsive.scss” changed. Running “compass:dist” (compass) task write style.css (0.001s)

But inside style.css all the code is gone and it is reset to the default content.

Any ideas out there…?


#2

Hello herbie4,

Are you doing changes in rtPanel child theme? Try change with theme name and check if the generated style.css contains that name.

Let me know if your changes are coming in generated style.css or not.

Thanks


#3

Yes, in the child-theme. I changed the child-theme name in package.json and in style.css already. After changes in scss file the style.css is reset to default again and empty.


#4

=SOLVED= I solved this already. I forgot to change the assets/rtpanel/syle.scss and uncomment the @import there. To change how the css gets written into style.css you can make changes in config.rb

Works like a dream now!


#5