rtMedia/Theme interaction issue - Need direction


#1

I'm working on a site and have found an issue. My Buddypress profiles are full width, and all the tabs work in Full Width, except for the "Media" tab which adds in the Sidebar.

Profile Link: http://test.kag.org/members/qurgh (Full Width)

Media Tab: http://test.kag.org/members/qurgh/media/ (Adds back in the sidebar)

This is probably an issue with my theme, and I have attempted every possible fix I could find (I've spent several hours on this issue already). I've copied rtMedia Templates to my theme, I've copied the both the default buddypress theme and the templates files to my theme and tried them in multiple different subdirectories. I've copied my theme's parent's buddypress files and tried editing them. I've examined so many different copies of /members/single/plugins.php without any luck. I was very careful and made sure to remove the last set of templates before working on the next as to not confuse the system. I even tried added random text to plugins.php and it never shows up, no matter which one I edit (even the one in the original theme). Is that still the file rtMedia uses?

The other plugins that tap into the profile work correctly (Docs and my own custom plugin) but rtMedia appears to be the only one that doesn't want to play right and I can't find out why. It does the same thing on the groups pages, everything but the Media tab is full width.

Any suggestions or directions to documentation on now to fix this would be very welcomed.


#2

You would need to make changes in the main.php file. Check this link out for the templating documentaion -> rtcamp.com/rtmedia/docs/developer/templating-system/.

You would need to remove the get_sidebar( $template_type ); line from it.


#3

Thanks. I tried that. I went into /wp-content/themes/myTheme/rtmedia/main.php and removed the call to get_sidebar(), but that didn’t make any difference. I tried adding some random text, and they showed up, but the sidebar line doesn’t seem to be doing anything… :frowning:


#4

After messing with the theme some more, it looks like it’s now using the rtMedia template correctly and the sidebar has gone.

Thanks for your help.


#5

Glad to know you could get it sorted :)


#6